Jetson Nano 2GB Devkit not powering on correctly

Hello,

I reach out to you with a question regarding the powering on of an A02 version Jetson Nano 2GB developer kit. This version contains a USB-C power connector. I have a power switching supply and new USB-C cable going into the USB-C power connector. Both of these work with other devices. My microSD card is a 32GB UHS-I card with an image that was flashed from another Jetson nano board (an A02 version with a DC barrel jack) using Balena Etcher. This process went through successfully. When I power on the Nano, the green LED comes on, but none of the peripherals (USB, RJ45) come on, so I cannot see my monitor that I have attached.

Any recommendations would be greatly appreciated!

Hello all,

Problem solved. I went through the ‘Getting Started with Jetson Nano 2GB Developer Kit’ site found in the attached link. I realized that in order for my copied image that was flashed on another microSD card to work, I first had to flash the Jetson Nano image on a microSD card and insert this card into the Nano and setup all my settings. Once I did this, I removed my Jetson Nano microSD card and inserted my image microSD card and everything worked perfectly. I hope this helps!

Getting Started with Jetson Nano 2GB Developer Kit | NVIDIA Developer

Glad to know you resolved the problem.