Jetson NANO 2GB - Never fulfill the power requirements using the Official power slot (USB type C)

In the future i need to make this Jetson Nano 2GB to run from battery (for robot) and not using wall power.
So i buy this 4A regulator and make use of it. So here are my test approaches:

  1. My first test: I tried using the USB type C input slot, using output from my 4A regulator. Set the output to 5.2V And i always getting the socthem soctherm: OC ALARM 0x00000001
    Of course i checked the 5V pin on the GPIO of the jetson, and surprisingly it’s under 4.8V, i dont remember for sure. But this huge voltage drop reminds me of that time when i’m making reverse voltage protection using diode instead of switching mosfet!
    Current measurements never go above 1A.

  2. My 2nd test is using the output from my 4A regulator and connect it to the 5V GPIO pinout. 2 wires for 5V, and 2 wires for the GND so i’m pretty sure it could deliver more than 2A.
    This approach works good, I can run my jetson nano 2gb with 4k display, with USB wifi constantly transfering data, and also training small model with small batch without seeing the soctherm: OC ALARM 0x00000001 alarm. So i have more evidence that there is some circuit (or maybe diode) that’s causing the previous voltage drop.
    Current measurement can reach about 1.7A (impressive)!

Now recently I kept using my 2nd approach above, but suddenly when i’m training a model, the board shuts down, and i cant use the GPIO input for 5V powering anymore. Using USB type c with wall phone charger works, but still got the insufficient power problem as in 1st approach. So I could have damaged some part in the GPIO 5v pin or maybe my regulator/cable has now broken (hopefully the later).

  1. My 3rd test is using an ATX power supply with 80plus certification badge and using the 5V output that could deliver 16A (how about that). I’m pretty sure i used the 5V wire that only turned on when the ATX PSU is activated. So i’m not using the always-on 5V low current output which was meant for USB on Desktop motherboard.
    I connect this with USB Type C cable through the USB Type C power slot on the Jetson Nano. But I still get the soctherm: OC ALARM 0x00000001 even during idle just like my 1st test.

Does anybody share the same soctherm: OC ALARM 0x00000001 problem when running using the USB Type C input for this Jetson Nano 2GB?
And is it safe to use the 5V pin from the GPIO pinout to power the board? I want to test again using different power for the GPIO to check if my regulator is broken, but i’m afraid that i can break it further.

Hi, the power supply spec may say that it can deliver stable 5V/4A, but in reality voltage drops at peak current. It needs to measure input current & voltage together to confirm quality of power supply. You can run command ‘tegrastats’ to show the power and temperature status in real time.