Jetson Nano Dev Kit A02 U58 regulatoršŸ’„BurstšŸ’„Can the board still work?

So I messed up with my 5V4A Jack power supply (gave higher voltage or wrong terminals, I do not remember), But immedietly noticed the U58 regulator smoke up. From then on powering Jetson Nano devkit is not possible (either through 5V4A jack or microUSB port 2A) both does not work. So my DevKit is just lying around and my heart is broken.

I have attached macro pictures of U58 & surrounding parts.

Is there any way to make the carrier board work ?
Will the compute module still work or is it also damaged ?

please let me know/ help Jetson community & moderatorsā€¦



U58 is the load switch of 5V. Maybe you can remove it and power on system thru USB port (by U67) if no other components broken.

According to this post

@Trumany
I tried to remove U58 regulator, But not sure if i did correctly, still the DevKit is not powering up when powering through microUSB 5V2A .

I will try to post the macro pics after removal soon.

Hi @Trumany,

So I removed the U58 block, Iā€™m not sure if its correctly removed.
Also during the process I think I damaged/removed nearby components.
I can notice the nearby components missing also. Circled in red. Will it have any impact ?

I have attached the pictures, please have a look.
Still its not powering through microUSB 5V2A.

@Trumany

Also any other method to power Jetson Nano would be appreciated

It looks broken badly, not sure if it can be powered on by other method. For other supply option please refer the devkit user guide: https://developer.nvidia.com/embedded/dlc/Jetson_Nano_Developer_Kit_User_Guide

I just want to point out that usually a carrier board power issue does not harm the module itself. Youā€™d need a different board support package if you used an alternative carrier board, but the module is probably still good once on another carrier board (dev kit carrier boards are not sold separately).

@Trumany @linuxdev

Thanks for the support.
I totally missed out the opportunity to power it through GPIO.

I tried powering through GPIOs, after several attempts it worked,
My Jetson nano is back alive after 1.5 years.

for a stable GPIO power input I have ordered

https://www.amazon.com/UPS-Power-Module-Uninterruptible-Protection/dp/B08BRMZ4G6

Hope this works :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.