Jetson Nano: ssh: connect to host port 22: Connection timed out

I’m using Jetson nano on a separate monitor and not HEADLESS MODE.

I have my Jetson Nano setup with a 64gb sd card, but everytime I try to run the command “ssh host@ip” in the terminal I get the ssh: connect to host port 22: Connection timed out after 2-3 minutes of waiting. I get the same error on headless mode as well but right now im not concerned about that.

The output for ifconfig on the Jetson nano is:

The output for route:

Is your host PC in Ubuntu 16.04 or 18.04? Jetson Nano uses Jetpack 4 releases and we suggest connect to host PC in 16.04 or 18.04. The setup is tested and shall work well.

Hi, thanks for the reply! It uses Ubuntu 18.04.
Also I’ve found a way around this problem for anyone who’d like to know! I can help but this problem is totally based on your own setup!
I fixed it by using the ip address of my docker0 in the ifconfig output to connect to the ssh server!
If anyone still faces the issue let me know I’ll try to help out!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.