Jetson nano will not boot

I haven’t used my nano for several months and today I tried to fire it up. It does not boot. The green light comes on and the fan works but I get absolutely nothing on the HDMI screen. I checked the cable, the power supply, tried different SD cards but still nothing on the HDMI display. What else can I check?

Ok, I actually have 2 nanos. One on a Jetbot and one as stand alone. I booted up the jetbot and everything worked with the same HDMI cable and power supply. I then swapped just swapped then SD card stand alone still didn’t work. I then swapped the Jetbot top jetson board with the standalone top board and the Jetbot top board and standalone board all work. Looks like my top jetson board for my standalone development kit has gone belly up. Is there anything I can do with that board to try and make it work again and can I just replace that section if I can’t fix it?

Please use the serial console to check if the board really cannot boot or not.

Thanks, I don’t have a cable but it should be here in 2 days. So I’ll try that after I recieive it.

OK I tried the serial console on both the good nano (everything worked as the video said and on the proposed bad nano. I got absolutely nothing on the bad nano. The green power light came on and the fan started running but minicom received absolutely no input from the card. I am assuming this would mean the nano board is either not receiving the power from the dev board or it is belly up. Any other suggestions? And if none is there some way I can buy just the top nano board (or send this one back in for repair). I have had it for a while and it did work for some time. The dev board is an A02 with one camera port.

For the nano that cannot work, could you try to flash it with sdkmanager and see if it can get reflashed or not?

I will try. Thanks

Kent