Jetson orin suddenly gets stuck at login screen

i am working with a jetson orin NX, jetpack 5.1, it had worked well for a few days with coding, browsing, using cuda/GPU all had been good

suddenly when i power it on a new day, it booted well until the login screen, i entered the password, the screen got black in a sec, then the login screen is back again. This is an endless loop, i cannot access the desktop anymore
the password is correct as if i enter wrong password, it will report wrong password and not jumps into black screen in a sec.
i saw a couples of suggestion about nvidia driver but cannot access terminal by ctrl+alt+fn
would appreciate any help
I am able to access the serial port connection through other system but unable to chnage the environment variables and login to the system


What do you mean with this?
Can you please dump the full log from serial console?

I need to know the command to excecute in serial console to reset the environment variables

I don’t know what it has to do with environment variables.
Can you please dump the log first?

to work with cuda i have added 2 env variables
path and lib path using command
sudo -H gedit /etc/environment
from then the login screen is being struck and how many times I login its coming back to same lock screen

So you thought the env was set incorrectly and prevented you from logging in?
Then are you still able to login via serial console?

It’s hard to proceed if you don’t provide any log.
If you are using NVMe for booting, then it’s easy to modify it’s content by plugging it to your host PC.
If you are using eMMC, you can flash the device to boot from NVMe/USB drive so you can access file systems on the eMMC.

yes i am thinking adding thoose extra variable only causing the issue
I am able to login through serial console.
its not that i dont want to provide log.I dont know how
To provide log what is command i have to run in serial console ?

like in this post soloution how to do it

Then if you are able to login, I think it’s totally fine to restore /etc/environment with some CLI editors like vim or nano.

For capturing the log, if you are using minicom, check this:

If you are using picocom, just copy & paste whatever appears in the terminal window to a text file.

vi and nano commands are also not working in serial console
anthinng i have to install

Then what exactly do you get from serial console now?

Dump the log as a text file, please…
If you don’t have vim installed,

sudo apt update
sudo apt install vim

Well, so looks like the environment variables are totally messed up, so you cannot run some APPs that need to be located with PATH.
I think as ls still works while vi does not, you can only directly run binaries under /bin/ but not those under /usr/bin/ now. See if you can launch them with /usr/bin/vi.

Screenshot from 2023-09-18 14-29-21
environment file is readonly able to edit it but unable to save it
able to run vi but not ls
command is /bin/vi /etc/environment

Run it with sudo

sudo command not found bash error is comming
if I force it with w! the E212 cant open the file for writing is coming

Then would it work like this?

/usr/bin/sudo /bin/vi /etc/environment

1 Like

thanks a lot @DaveYYY issue has been solved and able to login to orin normally

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.