Jetson TX1 - power issues first, now won't start

I have been using a Jetson TX1 for a few months with the persistent issue that when using a 4 cell lipo the Jetson requires pushing the power on button multiple times to get the Jetson to turn on. Once on, no problem. When hooked up to the 19V power supply also no problem. I am not sure if this is related to the Jetson not starting or if it is just capturing the input voltage as stated:

https://devtalk.nvidia.com/default/topic/938799/?comment=4890965

I have not used the Jetson for about 1 week and upon going back to it, the Jetson will not turn on at all. The lights don’t turn on and using the micro-usb to access it the Jetson is not recognized by my desktop, lsusb doesn’t recognize the Jetson is plugged in. I have tried the hard reset with no luck. I have tried powering the Jetson with both the 4 cell lipo and power supply (which I checked, and it is outputting 19v).

I am beginning to assume the Jetson is dead but would appreciate any help to get it back up or something else to check. Thanks.

You can check below items before RMA:

  1. Check the input power current, if it is abnormal high, could be something broken and shorted to ground.
  2. Measure the signals as shown in figure 4, power up sequence, in OEM DG to find out which signal has problem.

Thanks for the quick response, can you please post a link to the document with figure 4?

OEM DG link:
http://developer.nvidia.com/embedded/dlc/jetson-tx1-oem-product-design-guide

All other docs are here:
https://developer.nvidia.com/embedded/downloads

I checked the current on a 4 cell lipo and it is 0.17 mA. The battery is at 16.5 V so it should be powering it. It is the same battery I have used previously to power it. Attempting to power on the Jetson causes no change in the current.

You mean the current appeared before pressing power on key?

What’s the level of force_recovery signal (‘S3’ button) ? If it is low, Jetson will enter recovery mode.