Jetson Tx2 Battery Power Precise Specs

Hi

I have followed a several posts here describing how to power the Jetson TX2 development board but still have no successful test. I wanted to ask if there are any exact specs for this.

I have looked at:

Here is what I have tried:

  • Initially tried to power it with a 14.4V & 22.6V (2/3 * 7.2V 5Ah lipos) setup connected to other components. Red power light is on but device does not boot up when I press the power button
  • Tried to power it separately at 14.4V and 22.6V (3 * 7.2V 5Ah lipos). The result is the same. Red power light indicates that it’s receiving power, but the device does not boot up.
  • I read in another discussion that you have to add filtering capacitors and I did. I tested up to 600uF Capacitance but saw no difference. I tried this both with other components connected (motor controller, some powered sensors) and also in an isolated setup with just the Jetson + the batteries. I’m ordering some caps and inductors but would appreciate some precise specs. I unfortunately do not have an oscilloscope I can access, but it seems like I might need one just identify the issue.

Strangely, Jetsonhacks has a video where he just plugs in a lipo battery source and a TK1 turns right on :o

Does anyone have any pointers here so I can work towards a reasonably predictable successful setup? What works? How much attenuation am I supposed to add? And should I expect similar issues once the robot is running? I have other loads such as 2 12V motors, another microcotroller and some sensors. Should I just run the Tx2 isolated from everything else?

Thanks for any advice. Happy to answer any questions if needed as well.

hello nskapf,

are you using Jetson TX2 DevKit, or you’re having a customize board? in addition, did you enable auto power-on?
please also refer to Jetson TX2 Series OEM Product Design Guide, check chapter-4.0 for the [Table 5. Power & System Pin Descriptions].
thanks

Hi Jerry. Thanks for responding.

I am using the DevKit. I do not have auto-power on. Should I ? I do not understand it’s relevance to this so please elaborate.

The link that you shared is a dead-end - there is no document. I searched for and found this document at usermanual.wiki: https://usermanual.wiki/Pdf/jetsontx2oemproductdesignguide.2134990230/view

Referencing Chapter 3.3 Power Sequencing, it seems like the VIN_PWR_BAD# signal is my issue:
VIN_PWR_BAD# signal is generated by the Carrier Board and passed to Jetson TX2 to keep the Tegra processor powered off until the VDD_IN supply is stable and it is possible to power up any standby circuits on Jetson TX2 . This signal prevents the Tegra processor from powering up prematurely before the Carrier Board has charged up its decoupling capacitors and power to Jetson TX2 is stable.

I am now trying to connect with a local university to access an oscilloscope to examine my input voltage while waiting for some caps in the mail. Not really sure what else I can do here so feel free to chime in.

I’ve managed to get my hands on some additional capacitors in the last few hours. I have 3660uF in total decoupling capacitance across the power line but the TX2 is indicating receiving power (red light) but is still not turning on. I did a sanity check with the regular adapter and the TX2 still powers on with that.

hello nskapf,

it’s the link to the file source via Jetson Download Center,
for an alternative way, please visit https://developer.nvidia.com/embedded/downloads and searching the file [Jetson TX2 Series OEM Product Design Guide] for reference.

Finally got things working. I grabbed one of my extra regulators and use that as my filter. It worked (and saved me shopping around for caps and inductors) Hopefully this helps someone out there.

It’s a 300W Step down buck converter. Got it from Amazon.ca a while ago: https://www.amazon.ca/gp/product/B07L2WGBPR/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.