Jetson TX2 Power switched off when powering up with 24v 350AH Battery

So I am using Jetson TX2 as a controller on a battery operated pallet truck for autonomous navigation. The board is powered by the vehicle’s battery( 24v 350 Ah lead acid) through a buck converter. The problem is whenever I try to lift up the vehicle’s fork, Jetson gets switched off. The problem does not occur when lifting the fork down. We tried using a boost converter but still the problem persisted. The lift system is a hydraulic system actuated by a DC motor. We tried connecting other 19v devices like pcs and those devices did not have any problem. It only happens with Jetson TX2. What would be the best solution to solve this?

The Jetson is very sensitive to quality of power regulation, and I suspect you simply need higher quality regulation (especially true since electric motors are inductive and cause larger fluctuations). One test you could do is to place a large capacitor (e.g., 2000uF to 5000uF) right next to where the power goes into the Jetson itself to somewhat fake regulation improvement.

How exactly to mount the capacitor? Is it at the power barrel or from the source?

As close as possible to the barrel connector is best. This helps avoid issues with resistance in the power wiring (and thicker power cables are often a good idea as well).

We tried 4400 uF at the power barrel. But still the TX2 powered off when lifting the forks.

After this now, the Jetson is not switching ON at all. The CR5 led just lights up red and goes out. It’s not going into recovery mode as well.

I did just notice that in the title of the thread you are using 24V, then you mention a buck converter, taking this down to a proper voltage of 19V. Since this switches off when lifting the vehicle fork, this tends to say there is a large electric motor on the 24V side. So far we’ve only covered a way to avoid shutdown/reboot for a running Jetson when the fork suddenly consumes a lot of current from the main battery, but I’m going to also suggest that if the buck converter is not handling power spikes, then it may have passed these on to the Jetson, which is an additional problem (spikes can damage the Jetson in ways a simple voltage drop cannot…most of the time the carrier board and not the module itself would be damaged with some spikes).

Do you happen to have an oscilloscope handy which you could use at the input barrel jack to see an actual image of how that voltage changes at the moment of starting the lift fork?

Also, if you don’t have an oscilloscope, can you verify that the Jetson still works (or fails to start) using a power supply known to work with other Jetsons (assumes you have more than one Jetson, but it would still be useful to try other power supplies)? I am wondering if the carrier board is damaged (in case of power failure damage it is almost always the carrier board which fails, while the module remains working).

Also, can you verify this is a development kit and not a commercial module with a third party carrier board?

  1. I’m not having an oscilloscope with me right now. I will check to see if one can be bought
  2. Right now, I have a Jetson AGX module. I tried its power supply with TX2. The Jetson is still not switching ON. I also tried a couple of other 19v power supplies, still it does not start
  3. I can confirm that this a development kit.

So when you say the module might still work, is there a way we can get it to start? At least for sometime so as to enable me to take a backup?

It sounds like there was a need to protect against spikes which that particular buck converter does not quite cover. It is a strong chance the carrier board is damaged. To that extent, you could test on any other carrier board. Unfortunately, that means buying a second dev kit (you can’t buy the dev kit carrier board separately, but it might be good to have a spare module anyway), or else a third party carrier board. The problem with a third party carrier board is that you would have to change firmware (device tree for the most part) before it would work correctly.

You can make a backup from most any carrier board (provided it works). Unless the carrier board is working though there is no method of backing it up. My opinion on this is that your cheapest and quickest route is to buy another dev kit. If this is not available, then you could look at the third party carrier boards, but this would cost slightly more and you would need to deal with new firmware (you could still save whatever content you have on the module if the module works, and it is likely the module does work).

Btw, if the unit is still in warranty, then you could get it replaced. You might still want a second unit to clone from before any kind of RMA replacement.

A lot happened in the last few days:-

  1. The TX2 would not switch ON normally, but every day it will just ON for exactly 5 mins. After 5 mins it will just switch OFF. I took backups in bits and pieces everyday
  2. Luckily I had a Xavier AGX, which I am using as a backup. And the “device getting off when lifting the forks” issue is still present with Xavier AGX as well.
  3. Today something different happened. I used Xavier’s power cable to power ON the TX2 and it works perfectly, i.e so far it has not Switched OFF.

The only difference I can notice between TX2’s and AGX’s cables is that the AGX cable (pic attached below) has this capacitor(or is it a booster?) attached before the barrel. Could this mean that using this particular cable could solve the issue? I will be trying this out with AGX while I lift the forks. But just need an opinion before I proceed.

It is a noise filter, e.g., ferrite bead (this probably helps against higher frequency noises, but not lower frequency noises). Everything you’ve discovered says the issue is one of power regulation being insufficient. Quite possibly the ferrite bead has nothing to do with the official power supply in your case, but it wouldn’t hurt to filter higher frequency noise. Whatever your source of power regulation is when tied to the lift may need upgrading in terms of regulation specs.