Power Requirement for Jetson TX2 Development Board

Hi,

I have a Jetson TX2 development board. I wanted to know what are the power requirements for the carrier board itself as I couldn’t find any information about that on available datasheets.
There is detailed information about the jetson module itself but not much about the carrier.
Specifically, I want to know what is the working input voltage range for the carrier and how much is the current drain.
The peripherals that I am using are: 2 USB ports (one powering a camera and the other one is for communication). Wireless module.
The kit is expected to run a deep network near its maximum capacity. There could also be intensive CPU usage.

I want to know if a 12V battery with 5Amp current would be enough for our application. I didn’t want to connect the board before making sure that it wouldn’t damage it.

The system ships with a 19V 4.74A power supply, 90W max. Honestly, the best way to accurately determine the watts needed is to throw a meter in series with the power line while you have it running fully loaded. Anything else is going to be an estimate. The USB ports are limited in the number of amps you can pull from them but you don’t seem to have much on them so it doesn’t seem like an issue.

I don’t know the input voltage range of the development board but if it supports 12V, my guess would be 12V 5A would be fine for what you are doing. But I’d check with a meter. I’m running 12V, 4A with a third party carrier board, a powered hub and a few different USB devices including a depth camera. I’m using the Orbbec Orbitty carrier board, it has a working input voltage of

Input Voltage Range: +9V to +15V DC
TX1 Module Consumption: 6.5W to 15W (dependent on CPU/GPU utilization)
Orbitty Carrier Consumption: 2W to 6W (dependent on draw of peripheral ports)

I have a 12V 5A transformer on the way, so 60W, because my single power supply is also powering the hub and some small servos and I wanted some extra room. I’m just using the 4A temporarily because it was lying around.

This writeup:
https://devblogs.nvidia.com/parallelforall/jetson-tx2-delivers-twice-intelligence-edge/

shows the TX2 (module only or with board? it isn’t clear) pulling 12.4W @ max clock. I can’t imagine the development carrier board is pulling more than, say, 10W. That plus your USB devices still allow a 60W a lot of room, even with loss. But a meter would provide confidence.

12V 5A is 60 Watts.
The TX1 draws 15 Watts at full tilt.
USB ports can regularly draw at most 2.5W each (500 mA times 5 V) although USB 3 lets you draw more for certain devices.
I see now way that the board + Jetson will draw more than, say, 25W total. The board doesn’t get as hot as the module, and doesn’t need cooling fans, so it simply can’t create that much heat, which means it doesn’t draw that much power.

I had a KillAWatt sitting around so I threw it on the power supply I was using to see the rough watts my TX2 setup was actually pulling. This is direct from the wall before power supply. My 12V power supply also powers my powered USB hub and some servos.

What I saw was: 7W booting up, 11W stable with X and a USB camera on and playing to display, 14W with that plus servo running. I switched from default cpu to max cpu and ran x11perf along with a couple other things and it seemed to stick around 12W. CPUs/GPUs weren’t maxed out but that shouldn’t add too much. This was with the Orbitty carrier board. Also, 3W with the OS shutdown but device still plugged in with the one blue light lit.

Just a note on USB port power… the Orbitty USB port is spec’d as follows:

1 x USB 3.0 (5Gbps, 1A Maximum Current Sourcing)

If you are using a hub and/or high amp USB device, be sure to check the rating on the specific USB port you are using.

Note that switching power supplies typically have much worse efficiency at low loads, because there is a bit of “base load” (some current needed to regulate) as well as cost of driving the switching electronics (gate drivers, controller, etc.)
Thus, the power draw from “plugged in but turned off” may be almost entirely the power supply itself.
As you add load, the base cost of the switching supply gets amortized over more delivered power, but instead the losses in the switch (MOSFET on resistance and inductor on resistance, for example) start dominating; these are proportional to amount of current drawn.

Anyway – a 12V 5A capable battery would do fine on a Jetson setup.

Also, where does this 5A capacity limit come from? If it’s a “5 Ah” battery, this means that the battery is rated to deliver 5A for one hour as energy content, but it doesn’t say a whole lot of how much current it can actually deliver. I use some batteries that can deliver 100 A, but only for a few minutes, if you use them at that rate. A safe assumption with modern (Lithium-based) batteries is that the battery can deliver AT LEAST 1 times the Ah rating in constant current, but usually more than that.

I finally found a bit of official information regarding the carrier board power requirements here:
http://developer.nvidia.com/embedded/dlc/jetson-tx1-tx2-developer-kit-carrier-board-design-files

The schematics for the power tree states that the main input power ranges between 5V to 19.5V. It doesn’t completely answer all question about the power requirements. E.g. what is the maximum tolerable voltage (I doubt that the max is equal to the default operating voltage of the charger at 19V). What is the minimum required current to boot.

The first question is important if you want to use a battery slightly more than 19V. It would be nice to get a confirmation on the max voltage. Jetson module can handle up to 30V but I am not sure about the peripherals.

The reason for the second question is the issue that I faced when trying to boot up the Jetson with the TrutleBot battery. The battery (Li-Ion) claims that it can provide 5A at 12V. However, it failed to boot up the kit. Then I tried with a power supply at 12V with a varying current limit. I saw that the board fails to boot for current limit of 0.7A or lower. Even though, as others have observed, the nominal drain is about 0.5A with the peripherals that I have been using. Note that I didn’t see any voltage drop on a multi-meter when I pressed the power button. Later I managed to run it with a 9.5V battery with 5A max current.

I am still confused why the TurtleBot battery failed. I was guessing that there could be a current spike right at power up which the battery cannot handle (which is odd given the battery type). I will put a Capacitor at the battery out to test this. I didn’t go through the schematics in details so not sure if there is any capacitor before the button.

That sounds confusing.

Are you sure that the Turtlebot battery claims to be able to provide 5A, as opposed to being rated at 5 Ah of capacity?

When you say “battery,” is it a raw cell pack, or does it have protective circuits in it?

How old is the TurtleBot battery? Maybe it has really high internal resistance and can’t actually provide enough current? Is this TurtleBot, TurtleBot 2, or TurtleBot 3? Default or large-capacity battery?

If you plug in some other 12V device (light, radio, or whatever) that draws less than 5A into the battery, does that device work?

And, in the spirit of “did you plug it in?,” are you sure the battery is charged? (Gotta ask :-)

It is a turtlebot 2. I tried it with two of them, both fairly new with fully charged battery. Got the same results.

Battery Specs:

STANDARD BATTERY 2200 mAh Li-Ion
EXTENDED BATTERY 4400 mAh Li-Ion
USER POWER 5 V and 19V (1A), 12 V (1.5A), 12V (5A)

We have the standard version and used the 12V (5A) output.

There should be a protective circuit inside but I don’t know its characteristics (impedance and admittance).

As I mentioned we tested it with a power supply. We observed a that at least 0.7A at 12V is required to boot. But this reading is only as accurate as our multimeter and we didn’t have a sensor to measure possible current spikes. The power supply may be able to handle very short current surges even above its current limit.

I see, the rating is on the Kobuki base, not the battery itself. I haven’t actually messed around with that, so I have no better suggestions than you already have at this point: maybe it’s a start-up surge?
Btw, for being an “open source” platform, actually finding the schematics of the TurtleBot is surprisingly hard… (I know the Trossen Robotics folks are trying to re-start Turtlebot in the direction of Intel Galileo; that’ll be interesting to see how it goes.)

You didn’t report that you tried running a flashlight or car radio or something off the battery output, but if the Turtlebot itself works, then presumably that works… (Hmm, the docs seem to say that the 12V/5A is the “arm power supply” – have you actually tried an arm here? It could be that this particular output is somehow bad?)

The other thing to try would be to add a fat inductor (I have some 220 uH 8A ones that I got on a fire sale; something like that should work) in series between battery and Jetson. That will presumably prevent spikes from drawing as much in the beginning. If that makes it work (as a filter,) then you know your theory is correct.

Or buy a 3S LiPo pack at your local hobby shop or online retailer, and use that instead! Draw-back: Needs special charger, and if you ever forget to unplug it and run it down to empty, the battery is dead and would be dangerous to try to recover. Things are cheap when made in China!

Generally speaking, batteries are in a very good condition.

Hmm, the docs seem to say that the 12V/5A is the “arm power supply” – have you actually tried an arm here? It could be that this particular output is somehow bad?
Could you please provide a link to this doc. I don’t see why a battery should work for arms only.

I think that the board needs the high start-up current to boot. Therefore, I think a capacitor should be placed to provide it not an inductor. But again, I am not even sure that there is a current spike. Maybe someone with better instruments can look it up.

I guess the batteries that you pointed out can do the job. We found some 20+ years old batteries lying around which, surprisingly, managed to power the board. The only issue is the inconvenience of using another set of batteries when the robot has its own.

The Kobuki user manual is here: http://kobuki.yujinrobot.com/wiki/online-user-guide/
It documents 12V 5A as “arm power” – I presume that mean it doesn’t HAVE to power an arm, though.
But perhaps there’s some remote control switch for this, related to an arm? Or not?
If you drive some other load (flashlight) on this port, then that’ll answer that question definitively.

The problem with a capacitor is that it will draw the most current when it’s the least charged. It starts out with an effective impedance of zero Ohms (a short) plus ESR. Especially ceramic capacitors have very low ESR and can draw very high currents at initial connection. It may very well be that the Jetson has a bank of ceramic capacitors for input filtering on the motherboard.
(The low ESR also means that they don’t dampen much, and thus any inductance in your power leads or board can form an oscillator with the capacitors and ring at up to twice your input voltage when first connected!)

If the problem is, as you theorize, that there is an initial spike higher than 5A, and that some internal protection in the Kobuki base shuts it off because of this, then a capacitor will not solve that problem, because the capacitor itself will cause a high initial draw when it first charges, and thus trigger the shut-off.

The thinking was that the inductance in the inductor softens the initial draw of the source power.
Another option is to use an NTC resistor, which starts out with high resistance, but quickly warms itself up and ends with low resistance. These are known as “inrush current limiters” and are easy to find from places like Digi-Key / Mouser / etc.

It’s late, and I don’t have a good 12V plug with a sense resistor to hook up a scope to answer the question “what’s the magnitude of the inrush current” right now, sorry.
I would like to hear how powering something else with that 12V 5A output works out, though! It seems far-fetched that the Jetson should be so special in start-up requirements. (But not impossible, of course.)
So, I’m intrigued by the mystery!

Here’s what I don’t understand about the Turtlebot 2 after looking at it. It says it has these outputs:

19V/2A​ : ​ Laptop power supply
12V/5A: Arm power supply
12v/1.5A: Microsoft Kinect power supply
5V/1A: General power supply

However, the power adapter it uses is rated:

Voltage: 19V
Ampere: 3.16A

Now, I’m assuming when you run it, you can just plug in the power adapter and don’t put in a battery as well? If so, the power adapter is 60W and 12V/5A is 60W right there. Nothing left for the 12v/1.5A, 5V/1A, etc. Or do you use a battery along with the power adapter? I see:

“But you cannot use the 19V connector to feed the nettop in normal operation, as it is only enabled when the robot is charging. You can only use the 12V connectors to power an on-board computer.”

But ignoring the 19V, 60W still isn’t enough power for all that. Are you running it all off the single battery alone? Is the TX2 plugged in at the same time as the rest of the Turtlebot stuff when you are testing starting it up or are you just using the battery directly to the TX2 development board?

Looking at the TX1 and not the TX2, I see the comments of this page"

http://www.jetsonhacks.com/2016/02/01/autonomous-deep-learning-robot/
“Do you want to power your TX1 with kobuki battery ???..”

That post is also in this thread which is about the TX1 and batteries:
https://devtalk.nvidia.com/default/topic/914529/jetson-tx1/battery-for-jetson-tx1/4

My random guess would be that it might be voltage drop due to current draw at startup and my random guess would be that the current draw at startup isn’t actually that high. Both speculation.

Here’s my quick short-term solution:

30ah 19v 3.5a external laptop battery from Amazon Prime $79.99 :) It’s also available on Aliexpress for $10 less if you can wait a few more days!

Here’s the Amazon link http://a.co/852Pfwr

Hi, I’m trying to boot-up a Jetson TX2 with the external power bank that was recommended in above post, specifically this one: “30ah 19v 3.5a external laptop battery from Amazon Prime $79.99”: http://a.co/852Pfwr

However, my TX2 doesn’t boot-up with that supply. As per the specs of the battery, it says that it gives 19.2v with up to 4.5A and 30000 mAh. :(

Has anyone had similar experiences with the batteries? or am I missing something?

I read in following post that a capacitor might be needed, is there any info on where and how can I add it:
https://devtalk.nvidia.com/default/topic/914529/jetson-tx1/battery-for-jetson-tx1/4

Thanks!

Jetsons are sensitive to very short power drop spikes at the moment of powering on. You’d simply put a capacitor as close as possible to where the power cable connects to the Jetson.

My experience is that it’s not just during power-on, but while on, too.
Doesn’t change the advice, though:

  • capacitor by the barrel connector (I use 1 mF 35 V)
  • short, reasonably thick wiring (I use 20 ga, and no more than 15 inches)
  • solid barrel connector contact (I have some trouble here…)

A buck/boost converter would also be advisable if that same battery powers anything else.

Thanks for the help!, what finally solved the problem for me was:

  • Change the barrel connector (it was in fact a loose connector).
  • Change the battery pack. The battery pack was shutting down itself after some time (‘googling’ around apparently this is a common ‘feature’ in some battery banks which depends in the current consumption, and I’m guessing Jetson consumption was going very low), so I used this one instead, and it’s been working fine: https://www.amazon.com/gp/product/B00MHNQIR2/ref=od_aui_detailpages00?ie=UTF8&psc=1

@Ingridvoik

Thank you for your post. I’ve been using the battery you posted. It was working fine for a while but now it powers off automatically even tho it is charged. I’m wondering if it is because Jetson is overheated. I am trying to figure out how to fix it. Have you encountered any problems with your battery and Jetson TX2?

@kimyejin2000

I haven’t seen those issues with the battery. One thing is that I’m only powering the Jetson with one battery (nothing else), I do have a second similar battery for powering a display.
However, I’m only running around 1.5hr with the batteries (the battery can hold the display only for that time) and usually I charge them over-night (I’ve noticed that sometimes the battery reports as if it still has good charge, but it is not accurate and only charging the battery over-night fully re-charges it).

To avoid re-charging that often, I’ve started experimenting with this other battery that is 11Ah (instead of 3Ah), so far it’s been good, but I’m still in experimental phase…: https://www.amazon.com/gp/product/B016BJCRUO/ref=oh_aui_detailpage_o00_s01?ie=UTF8&psc=1

…hope that some of this might help.