Jetson TX2 dev kit fails to flash after "Cannot Open USB"

A few days ago, I found my dev board shut down and regardless of what I tried (reboot, unplug/plug power, different monitors) I couldn’t get any display on the hdmi and my router wasn’t picking it up after startup (I don’t have a serial console). I was running R32 4.4 and had done an apt upgrade a few days earlier w/ a restart afterwards and nothing unusual. This same thing (finding it powered off and end up having to reflash) has happened at least once in the past.

Anyways I’ve been trying to flash with no success using both the sdkmanager and flash.sh w/ various jetpack versions (4.6.2, 4.6r3, 4.5.1, 4.5) w/ the same result every time no matter how many hours I wait:

[ 9.2347 ] Sending blob
[ 9.2348 ] […] 100%
[ 9.7614 ]
[ 9.7665 ] tegrarcm_v2 --boot recovery
[ 9.7698 ] Applet version 01.00.0000
[ 9.8451 ]
[ 10.8523 ] tegrarcm_v2 --isapplet
[ 11.5788 ]
[ 11.5885 ] tegradevflash_v2 --iscpubl
[ 11.5907 ] Cannot Open USB

Sometimes it doesn’t even show the full error and just shows:

18:47:57 INFO: Flash Jetson TX2 - flash: [ 12.9081 ] C

I put it into recovery mode each time (press pwr button while holding rec then let go of rec) and can see from lsusb afterwards the 0955:7c18 ID for recovery:
Bus 001 Device 051: ID 0955:7c18 NVidia Corp.

My serial # starts w/ 699 but it ends w/ 501 and not D01 or greater so I don’t think this has to do with the PCN that I’ve seen referred to on here??

So I’m wondering is it basically bricked somehow? Am I missing something obvious? Can I even more forward in troubleshooting unless I have a serial console?

Any help is appreciated as I’m basically dead in the water at this point.

Please check if latest jetpack can flash it or not.

Please check if you have any other jetson TX2 can validate the hardware (your usb cable and host).

Please dump the uart log when this “Cannot open USB” error happened.