Jetson tx2 developer kit will support jetpack version 4+

I tried to flash jetpack 4.3.6 on tx2 developer kit(MFG. month 2019) but peripherals(usg,hdmi,rj45) won’t working. Only jetpack version 3.3 is only working. please help if jetpack 4+ will work.


Actually there is no jetpack4.3.6. Only jetpack4.3, so not quite sure what you are talking about.

Also, TX2 devkit is supported on every jetpack4 version. Are you sure that is devkit?

Any kernel log to dump so that we can see what happened on your board?

Sorry my bad it’s actually 4.6.3. After installing only os image and when pressed on(power) button of jetson tx2 developer board the HDMI,usb ports are not working.

You’ll be ahead of the debug game if you include:

  • Full serial console boot log. That’s the kernel log dump.
  • The log file “/var/log/Xorg.0.log”. This is specific to the GUI.

Note that ssh access might still work, whereby only the GUI is failed. The serial console will answer that if you don’t know the IP address. You might also try the key binding CTRL-ALT-F3.

Do you mean after you re-flash the TX2 developer kit through SDKManager, there is no HDMI output and the type-A port on developer kit does not work?

Yes after flashing os image the HDMI,usb port,rj45 port won’t working.

Please use below method to dump the log from serial console and share the dmesg to us.

As per the jetsonhacks document I tried to get serial data from uart communication. But there is no data coming and it’s still unresponsive.


Are you sure your board can still get flashed by sdkmanager? If it can still get flashed, then it is your setup that has some problem so that the serial console cannot show you the log.

Sorry it’s my problem😅. There is already a sd card with jetpack 3.3 flashed image in developer kit. When I removed it’s working and I installed jetpack 4.6.3 successfully. Also thanks for valuable and quick support.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.