Jetson TX2 on Auvidea J120 carrier board with Jetpack 4.5

Hello,

I’m trying to use the Jetson TX2 on the Auvidea carrier board J120 rev 7 with Jetpack 4.5 or newer. I using this board because of its small formfactor the the 2 USB ports (I need at least one USB 3 port).

There is no new firmware since February 2020, which is for Jetpack 4.3.
I’ve tried the USB patches described under TX2 firmware table, but then the Jetson does not boot anymore. Without these patches the Jetson TX2 boots, but the USB ports do not work.

With the firmware for Jetpack 4.3 all worked, also the 2 USB ports. But there I have a problem with an other library.

Does anyone knows which kernel and device tree patches I need to apply?

Thanks for help.

Please understand that any device tree change comes along with hardware change.

Which means if no schematic of the board is provided, it is not possible to provide a correct device tree change. Thus, you should consult with Auvidea with such info first if you really want to configure the device tree.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.