Jetson Xavier can not turn on

Hi,

My jetson xavier can not turn on when connecting to power. It is connected to a robot and was running perfectly. Then I let the robot sat for a while and Xavier automatically turned off. I tried to turn it back on but it does not respond. I have also tried pulling out battery (I use battery to power it) then put it back in, but it doesn’t help either.

Can I get some help?

Cheers

Hi,

Are you still able to see any log from serial console?

Hi WayneWWW,

Sorry, I don’t have any information about it since I can’t turn it on.

Is this your custom carrier board?

Are you able to check with power supply from cable?

Hi WayneWWW,

Thanks for replying.

Yes, I am using a custom carrier board.

I am sure that the battery is providing power through cables, and I have also tried to power Xavier with normal adapters. The issue remains.

Could you move the module to Xavier devkit (if you have one?) and see if it still works?

Hi WayneWWW,

Unfortunately I do not own a devkit.

Do you have other xavier modules to verify that issue only happens to one xavier module?

Hi WayneWWW,

Sorry I can not find any other devices to cross check, this is the first the only Xavier that I’ve had.

If this board is even not able to boot up, I would suggest you can RMA this module.

But you should be confident that this issue is not due to your carrier board. Or the next module may have the same problem too.