Jetsono nano will not boot

This is a replacement because my other one had a broken csi connector model B01

I get a error message:

production mode:unfused
boot recovery kernal
boot safe mode
forced recovery
unlock bootloader
lock bootloader
factory data reset

Flash your device with sdkmanager first.

my OS is not supported Ubuntu 20.04

Find a native x64 host to support ubuntu 18.04.

It did not work sdk manager could not detect Jetson Nano after formatting my spare laptop and installing Ubuntu 18.04 I don’t what to do, I tried a frash install of Jetson Devkit image and using a backup image of my system with ROS, opencv 4.5,3 and tensorflow installed

Did you ever put your jetson nano into recovery mode before doing the flash?

I can not do that,I don’t get any power to the usb port. I tried both a wireless keyboard and a wired keyboard but the power light on the keyboard does not light up so I can not scroll down the menu. That is the first thing I would have tried. I am a A+ certified computer repair technician. and I have built many Pc’s and all of them have in the heart of them are Nvidia geforce video cards I have never liked the ATI Radeon video cards so i am a loyal customer.

Not sure if any of this will help, but a few things come to mind…

The micro-OTG connector of a Nano only works as “device mode”, and since it cannot be a host, if you connect any kind of keyboard there, then it won’t work…those are devices too, and it needs a host. When fully booted there are some utility functions associated with that port. When in recovery mode (you have to short the recovery pin to ground while either starting power or resetting power, then let go of the recovery pin short), then the “driver package” recognizes the Nano as a custom USB device (and the driver package runs on the Ubuntu host PC). I assume you are using the full-sized USB port for keyboard/mouse, so this is unlikely an issue, but it is useful to know about the micro-OTG port. You’ll still want to be sure to check you’ve jumpered the correct pins to get to recovery mode.

Note that on the Linux host PC, you can run this command to monitor USB devices with an NVIDIA ID:
watch -n 1 lsusb -d '0955:'
…as you plug in or unplug the USB to the host PC you should see a USB device if (A) the Jetson is fully booted, or (B) the Jetson is in recovery mode.

Also, if you monitor “dmesg --follow” on the host PC, then as you plug in anything USB there should also be a note there.

Note that there are two ways of applying power to a Nano dev kit. I think there are some differences depending on model, but basically there is also a barrel connector, and if the barrel connector is used, then you must have the jumper installed. If the micro-OTG port is used to power the Nano, then the jumper should be removed. You’ll want to check the jumper for power issues.

Since Jetsons don’t have a BIOS (flashed software essentially flashes what would be a software version of a BIOS every time you flash, even on the SD card model when no SD card is present) you’ll never see early boot messages. If you really want to see what goes on you’ll need to use a serial console. See:

Trivia: Unlike the driver for desktop PC video cards the GPU in the Jetson can only use the custom driver installed from flash because it does not use the PCI bus (and PCI-based video detection schemes fail on a Jetson). The GPU driver will differ because it is directly integrated with the memory controller. Some of the video setup knowledge used for a desktop GPU setup does not apply to a Jetson.

I tried all of that. I have a ogt usb hub where I can power and attach a keyboard and removed the jumper, but I always use the barrel jack to power my jetson nano even when I attach it to my robot. I had to connect the jumper since it was setup to use the micro usb port. I tried to connect a TDI USB Serial Device converter now attached to ttyUSB0 but minicom could not locate the device. it located the Ftdi controller with using dmesg −−follow but could not locate the device with minicom. when I first tried to boot my jetson nano, it was before I tried to attach anything to the GPIO pins so I did not short them out and I used a esd wrist ground strap.

BTW I have been using the Raspberry Pi and Arduino for years, but I wanted something better suited for AI so I upgraded to the Jetson Nano.

Sounds like you didn’t know what is recovery mode doing on jetons nano.

Recovery mode is a status to make the board ready to get flashed by the sdkmanager. It is triggered by the rec pin and power on signal. Pure hardware triggered. Don’t need to care about the software running on the board.

Under recovery mode, the board is totally in a brick state, which means no OS is running. I shouldn’t hear you say anything about dmesg, keyboard or anything else that is operated over the jetson nano, because there is no OS running. It is not possible to run those commands.

Please follow point 0 in below post to know how to get into recovery mode.

If you are using “/dev/ttyUSB0”, then it means your FTDI serial UART has a USB end which is running on the Ubuntu host PC. No such device would be visible from the Jetson. On the host PC, if your serial console program can see ttyUSB0, but does not get a signal, then I would try to verify that the UART end which connects to the Jetson uses a 3.3V logic level. Other levels, e.g., 1.8V or 5V, won’t work.

If the above is all correct, then make sure that minicom is using settings of 115200 8N1 and no hardware (CTS/RTS) flow control.

1 Like