mlx4_vnic

mlx4_vnic seems to be missing from OFED 2.0 (I checked both the Ubuntu package as well as SLES). Any idea when it will show up? Especially the dkms flavour in Ubuntu :-)

Some strange things with releases.

In 2.0-2.0.5 for ubuntu there wasn’t vnic, but it appeared and worked “from the box” in 2.0-3.0.0 (worked with bridge 5020). But in 2.0-3.0.0 ib# interfaces were mising “from the box”. OS ubuntu 12.04.

Hi torkel,

For next MLNX OFED release schedule, please contact support@mellanox.com mailto:support@mellanox.com .

Hi torkel,

mlx4_vnic is currently not supported in MLNX OFED 2.0. Will be re-enabled in the future.

Check the Release Notes http://www.mellanox.com/related-docs/prod_software/Mellanox_OFED_Linux_Release_Notes_2_0-2_0_5.txt document:

- EoIB Vnic is currently not supported.

We will add support for it in future MLNX_OFED release.

Thanks so much for the question. Let me see if I can find the right person to look at this.

Hi torkel,

What other package did you previously use for mlx4_vnic?

mlx4_vnic was shipped in the 1.5.3 package. However it seems to be missing from the 2.0 release. The only traces of mlx4_vnic are in three files in mlnx-ofed-kernel-2.0/ofed_scripts/…

Hi Ali,

I obviously missed that part of the release notes, maybe because the Release notes in the Ubuntu package does not contain that part :-)

Any ETA when it be supported?

We are needing it for bridging our IB to our 10G-network via a BX5020.

We are currently in the process of upgrading our cluster to Ubuntu Precise (12.04) from Lucid (10.04) and with OFED 1.5.3 not installing/building out of the box on Precise we are stuck, unless we can find another way to bridge the traffic and/or you will release a new version with Vnic support…