Monitor blank after Jetpack installation

Hello,

I successfully flashed my Jetson Orin devkit using a Linux host machine. I’m then able to connect a monitor and go through the initial configuration of the OS (set username and password, set language, etc). At this point the device works and I’m able to reboot and use the monitor with no problem.

Then, if I go to install Jetpack just using
“sudo apt update
sudo apt dist-upgrade
sudo reboot
sudo apt install nvidia-jetpack”

Everything seems to work for a while. I can call trtexec and benchmark but when I restart the Jetson Orin the screen is black and goes into idle mode. I can no longer use the monitor.

I’ve tried connecting to the device with a serial connection to the host machine and the device responds and seems to work. I’m just not sure why the monitor no longer works.

Any help would be greatly appreciated! Thank you!

Dump kernel log → command “dmesg”

Dump display manager log → /var/log/Xorg.0.log.

Hi,

Here are the logs:
dmesg Output (55.5 KB)
Xorg Log Output (6.7 KB)

Thanks in advance!

Hi,

We tried the same steps on the devkit but we cannot reproduce your issue.

Are you still booting from the emmc? or you boot it from somewhere else?

And your log in this part looks like a mess. Could you share the clear log?

Please check

  1. Check with ‘lsmod’ if nvidia and nvidia-modeset modules are loaded?

  2. Check with “modinfo nvidia” and “modinfo nvidia-modeset”

  3. rmmod these modules and load them with debug logs enabled. Capture these logs:

    - sudo insmod /lib/modules/$(uname -r)/extra/opensrc-disp/nvidia.ko NVreg_RmMsg=":" rm_firmware_active="all"
    - sudo insmod /lib/modules/$(uname -r)/extra/opensrc-disp/nvidia-modeset.ko

Hi,

I tried reflashing the device with the new build R34.1.1 and everything seems to be working. I’m not sure if it was the new version that helped or if I was just making a mistake somewhere before but it works perfectly now. Thank you for your help!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.