MotionBVH for lidar model not enabled?

RTX lidar related issue when going from Isaac 2023.1.1 to 4.0.0, Win 10 the code ran fine in 2023.1.1,

When you copy the code found in latest docs below in the script editor, an INFO message is produced constantly “MotionBVH for lidar not enabled”? Really annoying as if your running print statements in the console this continues playing even when the sim is stopped.

https://docs.omniverse.nvidia.com/isaacsim/latest/features/sensors_simulation/isaac_sim_sensors_rtx_based_lidar.html

Secondly when i try to run the config for ZVISIONML30S the buffer and dataptr is empty suggesting that the sensor is not outputting anything. You can see in the two similar pics, that the second has data lidar_config = “Sick_TiM781” and the first lidar_config = “ZVISION_ML30S” does not Copy pasta that into the script editor, that should boot the ZVISION_ML30S head but I think there is an issue and It would be good to know how to resolve the BVH issue. Cheers! -------------------------------------------- import omni.kit.commands from pxr import Gf import omni.replicator.core as rep lidar_config = “ZVISION_ML30S”

  1. Create The Camera
    , sensor = omni.kit.commands.execute( “IsaacSensorCreateRtxLidar”, path=“/sensor”, parent=None, config=lidar_config, translation=(0, 0, 1.0), orientation=Gf.Quatd(1,0,0,0), )

  1. Create and Attach a render product to the camera

render_product = rep.create.render_product(sensor.GetPath(), [1, 1])

  1. Create Annotator to read the data from with annotator.get_data()

annotator = rep.AnnotatorRegistry.get_annotator(“RtxSensorCpuIsaacCreateRTXLidarScanBuffer”) annotator.attach(render_product)

  1. Create a Replicator Writer that “writes” points into the scene for debug viewing

writer = rep.writers.get(“RtxLidarDebugDrawPointCloudBuffer”) writer.attach(render_product)



Hello,

What GPU are you running Isaac Sim with? Isaac Sim 4.0.0 is using a newer version of the omni.sensors extensions, which now use MotionBVH for modeling the RTX lidar returns. MotionBVH is enabled if you are running with Vulkan (by default, Isaac Sim now enables Vulkan on Windows, unless you’ve explicitly disabled it) AND you’re running with Ampere architecture or later.

Are you seeing an empty dataptr forSick_TiM781 as well, or only ZVISION_ML305?

Thanks!

Thanks for the reply RTX 3090

the ZVISION_ML305

What is the work around for this atm?

I think this might be realted but i thought i would just put it here.

For the same issue, I am using XT_32_10hz RTX lidar in Isaac lab.
So what is MotionBVH and how to enable MotionBVH?
The log is full of this information:

As far as I’m aware an update is coming which should fix these so probably use 2023 for now if you are planning to use the lidar… A little annoying but is what it is

Thank you for your reply. It seems that isaac 4.0 is not a stable version. Looking forward to releasing a new version soon.