NetworkManager.service not found

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
[*] DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[*] Linux

Hardware Platform
[*] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[*] native Ubuntu 18.04

Hi! I have downloaded, created and flashed DRIVE AGX with DRIVE OS 5.2 based on the SDK manager.

I need my DRIVE AGX to access the local network to enable LAN ssh and internet apt-get.

However, when I accessed the target machine by ttyUSB, I found the networkmanager is missing on the target machine.

I have tried:

(1)Unmask the NetworkManager.service and NetworkManager-dispatcher.service

(2)Start them by “systemctl start NetworkManager.service” and “systemctl start NetworkManager-dispatcher.service” both fail.

Thanks in advance.

Hi @shaozhenlei,

Please refer to Finalize DRIVE AGX System Setup part in Install DRIVE with SDK Manager :: DRIVE Platform Installation Guide with NVIDIA SDK Manager for this topic. Thanks.

Thank you for replying @SteveNV
In the “Finalize DRIVE AGX System Setup” section.

  1. Connect Console to the target. I have done it successfully.

  2. “Enable SSH”. It seems irrelevant to the NetworkManager. But I still tried it and I met another problem as below

  3. “Enable Display”, It seems irrelevant to the NetworkManager too. But I still tried it in another issue: No HDMI signal output, and still not working by the way.

  4. “Enable Remote/VNC access”. It needs to access the internet in advance.

Am I missing something important?

Hi @shaozhenlei,

Could you please try to reset network service with the following command?
sudo systemctl restart systemd-networkd

Thanks for your advice, I tried this solution before, it won’t work because the network-manager is not installed. It seems that I installed a minimized version of DRIVE OS 5.2 and lots of softwares is missing.

However, I found that I have no need to enable NetworkManager to configure my network. I can just use the “ifconfig” and “route” tools.