No display

My Jetson Orin agx developer kit has a blank screen on boot up. It was previously working well and then stopped suddenly .

I have tried to go through the steps to flash the device using a host computer however now I am receiving this error when running the final command:
I appreciate your assistance. Thanks

[ 0.1753 ] tegrarcm_v2 --chip 0x23 0 --ismb2applet
[ 0.1784 ] File rcm_state open failed
[ 0.1803 ] ERROR: failed to read rcm_state
[ 0.1805 ]
[ 0.1933 ] --key None --getmode mode.txt
[ 0.1937 ] Assuming zero filled SBK key
[ 0.1815 ] Pre-processing config: tegra234-mb1-bct-device-p3701-0000.dts
Traceback (most recent call last):
File “/home/janice/Linux_for_Tegra/bootloader/./”, line 1383, in
File “/home/janice/Linux_for_Tegra/bootloader/./”, line 1217, in tegraflash_run_commands
File “/usr/lib/python3.10/”, line 217, in onecmd
return func(arg)
File “/home/janice/Linux_for_Tegra/bootloader/./”, line 855, in do_dump
self.chip_inst.tegraflash_dump(exports, args)
File “/home/janice/Linux_for_Tegra/bootloader/”, line 2387, in tegraflash_dump
File “/home/janice/Linux_for_Tegra/bootloader/”, line 358, in tegraflash_preprocess_configs
values[config] = self.run_cpp_tool(
File “/home/janice/Linux_for_Tegra/bootloader/”, line 3271, in run_cpp_tool
run_command(command, False)
File “/home/janice/Linux_for_Tegra/bootloader/”, line 277, in run_command
process = subprocess.Popen(cmd, stdout=subprocess.PIPE, stderr=subprocess.STDOUT, shell=use_shell, env=cmd_environ)
File “/usr/lib/python3.10/”, line 969, in init
self._execute_child(args, executable, preexec_fn, close_fds,
File “/usr/lib/python3.10/”, line 1845, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: ‘cpp’
Reading board information failed.

please share full log as txt file attachment.

full log of what exactly?

The log you posted in first comment only has partial log.

I need the log when you fail to flash from the beginning.

flashlog.txt (18.2 KB)

Here is full log. This is different than before. Now if fails on the libxm12-utils package. I have tried to download that package but it cannot find it despite updating apt. Not sure if I need to search a different repository.


It looks like host side problem. I mean if your apt-get update has some problem, then our flash tool cannot install the dependencies.

Are you sure it is a native ubuntu 18.04 /20.04 host?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.