"No graphics API" on attach

I’m trying to debug a Vulkan application I’m working on that uses vk_nv_ray_tracing. When I launch with auto attach it detects the process followed by “- Status: No graphics API”. I tried debugging vkcube.exe from the SDK and it works fine so it might have something to do with the rtx extension? I’m on a gtx 1080 ti with the latest gaming driver.

On a side note, I want to see if I setup my acceleration structures correctly, is this even possible on my graphics card?

Thank you for using Nsight Graphics and your feedback. I noticed you mentioned you are using a GTX1080 Ti. Ideally, you will want to upgrade to a Turing class GPU or better. However, the Vulkan Ray Tracing section of the site here https://developer.nvidia.com/vulkan-driver does imply you can use GeForce GTX 1080 Ti with 6GB of video memory or more. Does your card meet the requirement?

I do meet those requirements and have the beta driver. I tried a bunch of older versions of Nsight Graphics and now I’m encountering even more issues on the newest version, it cant find attachable processes. Even with manual attach the application’s process does not show up in the list.

Okay so its working now but not 100% how it should. So I am trying to just do a local program debug on my own machine. I had to start the Nvidia Nsight Remote Manager locally and in Nsight Graphics replace “localhost” with the host name from the Remote Manager like “192.168.xx.xx”. Everything works perfect now.

1 Like

Good to hear that everything is working now as expected. Again thanks for providing your feedback about Nsight Graphics and helping us to improve our tool. Please let us know if you experience further issues.

One other point on the issue where you had to start the Nvidia Nsight Remote Monitor.
It could be that there is a networking port conflict. Do you know whether your application uses networking on its own that have any networking configuration, tools, or firewalls that might be blocking or using the ports in question. The connection dialog will list the ports that are being scanned.

The application does not use any networking. Nsight is searching for attachable processes on " localhost:49152-49216". I also thought ports might be the issue but I couldn’t find a setting in Nsight to change it (to something more generic, like 8000).

Hello, just wanted to state that I encountered the same problem as niico0708 (Nsight graphics kept searching for an attachable process) and thanks to the solution found (just launch through remote), could also solve it.
Thank you niico0708