No IP address when connecting gigE camera directly to Jetson AGX Xavier


I’m trying to achieve is a simple task that I do regularly on other systems but for some reason it is not working on the Jetson AGX Xavier dev kit.

I got a GigE camera (Allied Vision Prosilica GT1290) that I connect to the Xavier via an ethernet cable. Both the camera and the Xavier are configured with a static IP address on the same subnet. The command ifconfig does not return an ip address and the network manager is saying “Cable unplugged”.

Now if I connect the same camera on my laptop (Ubuntu 16.04) with the exact same network configuration for static IP, subnet mask and default gateway, the connection is established and I can visualize the camera stream as expected.

Also, when I connect the Xavier and the camera via a router everything is working fine.

I tried to solve my initial problem by using a standard ethernet cable as well as a cross over cable without success. I also tried setting the Xavier and the camera in Static IP mode, DHCP, then LLA but nothing made it. Each time, ifconfig returns no IP. On the camera side, the green light is blinking periodically (~1Hz) and the orange light is off (for a valid connection, the green is solid ON and the orange light is flashing rapidly when there is communication)

A ping to the static camera IP address returns: “Destination Host Unreachable”. arp -a returns nothing and route returns two routes related to the docker interface.

Please Help!

Does the camera require PoE? The USB ports on Xavier does not support it. May need to connect to a PoE router.

The camera is actually powered via PoE but it has its own PoE supply module. In other words, the power does not come from the Xavier RJ45 connector. Here is a representation of the physical connection:

120V wall outlet <===============================╗
Xavier RJ45<=>Ethernet cable (crossover)<=>PoE module<=>Ethernet cable (standard)<=>Camera

The power is injected into the ethernet connection via the PoE supply module. PoE supply module act as a 1:1 passthrough for wires within the ethernet cable. The setup is equivalent to the following:

power supply <================================╗
Xavier RJ45 <==> Ethernet cable (crossover) <==> Camera

As I said in my original post, this exact same setup is working on other computers, and those do not support either PoE on their RJ45.

Any other ideas?


Since we don’t have the camera, may need other users to share experience. You may check dmesg of working and non-working cases. See if there is any clue. Or any error is shown in the log.