No signal on HDMI monitor and USB not powered

Hello,
we bought an NVIDIA Jetson TX2 and just tried to power it up and test everything.

We connected every cable according to the manua.
After plugging in the power connector and pressing in the PWR-button on the Jetson the following lights went on:
CR1 and CR2: green, CR5 and CR6: red.
We are receiving no signal on our HDMI monitor and also the USB-periphery is not showing any signs (on the keyboard, all lights are off).

We tried different periphery and different monitors. Also every periphery and monitor we tested worked on a Raspberry Pi.

Can you help us?

Regards,
Simon

The lights are normal.

If you are using a module which was not in a developer kit (meaning it didn’t arrive with a carrier board), then this is an empty module needing flash.

If this is a dev kit, then it isn’t uncommon for HDMI issues to not show on the GUI, but still have the unit otherwise correctly booted.

If you have the unit connected to a router, then you might try to ping its address or ssh in.

The best method to know what is going on is to use serial console. See:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Even if the GUI fails it might be possible to get to a text console via CTRL-ALT-F2.

We do have a developer kit, so there must be an OS already installed.

We have the Jetson connected to a network and were unable to find the IP adresse and therefor were unable to connect with SSH.

Because the keyboard is not working, we can not open a text console.

we tried to read the serial data with the serial monitor from our arduino uno. Here it is:

[0000.217] I> Welcome to MB2(TBoot-BPMP)(version: 01.00.160913-t186-M-00.00-mobile-2c57a56c)
20:28:11.614 -> [0000.225] I> Default Heap @ [0xd486400 - 0xd488400]
20:28:11.614 -> [0000.230] I> DMA Heap @ [0x84a00000 - 0x85300000]
20:28:11.614 -> [0000.234] I> bit @ 0xd480000
20:28:11.614 -> [0000.237] I> BR-BCT relocated to 0xd7220000
20:28:11.614 -> [0000.241] I> Boot-device: eMMC
20:28:11.614 -> [0000.245] I> sdmmc bdev is already initialized
20:28:11.614 -> [0000.250] I> pmic: reset reason (nverc)	: 0x4
20:28:11.614 -> [0000.254] I> Reading GPT from 512 for device 00000003
20:28:11.614 -> [0000.260] I> Reading GPT from 8388096 for device 00000003
20:28:11.661 -> [0000.267] I> Found 6 partitions in 00000003 device
20:28:11.661 -> [0000.272] I> Reading GPT from 512 for device 00010003
20:28:11.661 -> [0000.278] I> Found 17 partitions in 00010003 device
20:28:11.661 -> [0000.284] W> No valid slot number is found in scratch register
20:28:11.661 -> [0000.289] W> Return default slot: _a
20:28:11.661 -> [0000.293] I> A/B: bin_type (16) slot 0
20:28:11.661 -> [0000.296] I> Loading partition bpmp-fw at 0xd7800000
20:28:11.661 -> [0000.301] I> Reading two headers - addr:0xd7800000 blocks:1
20:28:11.661 -> [0000.307] I> Addr: 0xd7800000, start-block: 58740229, num_blocks: 1
20:28:11.661 -> [0000.321] I> Binary(16) of size 528400 is loaded @ 0xd7800000
20:28:11.661 -> [0000.327] W> No valid slot number is found in scratch register
20:28:11.708 -> [0000.333] W> Return default slot: _a
20:28:11.708 -> [0000.336] I> A/B: bin_type (17) slot 0
20:28:11.708 -> [0000.340] I> Loading partition bpmp-fw-dtb at 0xd79f0000
20:28:11.708 -> [0000.345] I> Reading two headers - addr:0xd79f0000 blocks:1
20:28:11.708 -> [0000.350] I> Addr: 0xd79f0000, start-block: 58741437, num_blocks: 1
20:28:11.708 -> [0000.364] I> Binary(17) of size 465760 is loaded @ 0xd798e200
20:28:11.708 -> [0000.542] I> BPMP-FW load address = 0xd7800000
20:28:11.708 -> [0000.546] I> BPMP-FW DTB load address = 0x5018e200
20:28:11.708 -> [0000.551] I> Loading SCE-FW ...
20:28:11.708 -> [0000.554] W> No valid slot number is found in scratch

We do have a developer kit, so there must be an OS already installed.
This is not correct. Even if you have a devkit, you still need to flash it when out of box.
Please go ahead using jetpack first.

Okay thank you.
We will test this in the next days and then reply back here.

You were right.
Flashing the Jetson solved the problem. Thank you!