No video display, first time turn on, fan on, lights on

I should flash bios or something.
what can I do?
is there some thing I can put on a sd card and reset the os?
I would even like to ping it from the Ethernet switch.

reading the forum about my problem I have learned I can’t boot of the sd card on Orin and I must use the headless, second computer attached through the micro-usb cable
My problem now is trying the setup instructions step one of the “initial setup in headless configuration” there is suppose to be only one COM port with VID of 0955 which they ALL have and a PID id of 7020 which none of them have (they all have 7045) as shown in picture.


I’m trying to follow the instructions from url…

also my OEM version is USB/VID_9055&PID_7045&REV_0001&MI_05 on COM5 of the four COM ports and the instructions are for REV_0002 so I have an original Orin before they have fixed this problem.
I guess what I need is the old instruction on how to flash the old UEFI, does anybody have that url? I need it.
I’m going to try the headless setup for ubuntu next, because the instruction are new and for REV_0002 of the UEFI (maybe I’m dealing with OS, with no display it’s hard to tell what I’m dealing with) I assume i will get the same “to many COM ports issue”
please help nvidia staff.

Trying step one of “headless setup” in ubuntu I am stuck at the similar problem 4 COM ports with none of them saying ttyAMC0. I tried both micro USB and USBC. Here is the pic…


At this point I will try to search for the old setup before this problem was fixed but this post is the first time i have used this forum. I need help. I need the old instructions for REV_0001. My only other Idea is to configure a M.2 ssd on a different orin and put it in mine and hope for the best.
please help!

a little bit more info…
minicommicrousb

this was a little bizarre, i switched to root, I copy and pasted the yellow /dev/ttyACM0 and… I’m in!!!
I’m so happy!!! I have no idea what to do but, I’m in, I feel like I’m dancing around in the vault at fort knoxs!

well things are not as great as i hoped…
the bottom of the minicom page says offline.
I will turn everything off and try again.

more info…
Orin pings and poles


orin in recovery mode does this on usbC

orin in recovery mode does the same as top of page on usb micro
the nvidia skd manager cant detect orin.

I would like to follow these instructions but (being kinda new to ubuntu, I think i need a ssh or minicom or some connection to the orin before I “sudo ./apply_binaries.sh” on my host computer. It just seams like that should be running on the orin and not my ubuntu 2004 computer. i did prepair the jetpack and have the sample files in rootfs.

well, that’s it. I can’t connect, sdk can’t connect, doesn’t even ask for a username or password. I think I have tried everything. Any suggestions, anybody?

I used SDK Manager with USB type C port next to the 40-pin connector and AGX Orin in recovery mode. Not sure if SDK Manager will work with micro USB debug port.

@pauljurczak I did try it. I thought I was clear, apparently I was not.
I will try that again. I have nothing to loose and a working Jetson Orin to gain. Your reply says more about you as a person because you would help a stranger than than it does about Nvidia technology. Thank you for replying to my plea for help. I so desperately need this thing to work and I think I have done everything except have a M.2 ssd made on a different Orin with a UEFI and os pre-installed. I don’t know if I could get it to boot of that without initial access to OS. I don’t really have that option though. I’m looking for an Orin club in Toronto.

I’ve spent a few hours trying to get the JetPack 5.1 and PyTorch working and it wasn’t a pleasant experience. Looking at your screenshots, I see two issues:

  1. Target device not detected, which should be fixed by using USB type C port next to the 40-pin connector and powering up AGX Orin with the middle button depressed.
  2. You selected Host Machine in Hardware Configuration, which you most likely don’t need. It’s a big download.

@pauljurczak I have not tried powering up the orin with the middle button depressed. I will try it, thanks.
I have put the example_file_system in rootfs so it should be fine using the copy I already have, if it doesn’t work I will grab the one from the internet.
I want to use the orin for stereo vision 3d and A.I. using these cameras…

Maybe Clara holoscan has some answers for me, if not I could stick with deepsteam. I use openCV with python.
I invented my own scan to cast metal fabrication system, I would like to know you Paul. join my club…

It might be a bit confusing. both localsailor and samuelbilow are my nvidia accounts. It happened during gtc 2022 when i couldn’t login.
I did boot in “recovery mode” (plugged it in while holding down middle button) but the orin was still not detected on the usbC port
what is the default username and password for the orin, like I said before, I never accessed it, no display, so it must be on the default setting.

thisMeansImConnectingUSBC
So if I can talk to the Orin over the usbC and change the files (I assume), can’t I install a new display driver or get the usbC to be detected by the SDK manager? I just don’t know enough about ubuntu. I’m sure if somebody gave me what to type at the command line I could get further.

I did try to connect over minicom
minicom -D /dev/ttyS0 -8 -b 115200
but it said at the bottom “offline”

looking more into this, I’m not talking to the usbC, I’m taking to my own computer, kind of like ipv4 127.0.0.1
Some loop-back function.

sshConnectionRefused
still nothing. I think I have tried everything.

I did try to connect with putty on windows11 on all 4 different com ports. On micro usb, nothing on usbC registers as COM. Ran as admin in windows.

@pauljurczak Thanks for your help, if you could go through the TensorRT install next that would be great, you had some problems (i guess) that I would prefer not to have. I have a course on openCV and tensorRT to do in march.


success.
lessons learned.
use the USB cable that comes with the Orin.
plug it into a usb2.0 not a 3.2 lightning usb port.
keep trying, you only loose when you quit.

I installed PyTorch, see: No PyTorch version for JetPack 5.1.