NVIDIA Jetson Xavier NX still not booting after flashing

After successfully flashing the NVIDIA Jetson Xavier NX kit, as it shows on the NVIDIA SDK Manager on my host Ubuntu, when I power on the Jetson it still doesn’t boot up properly. Initially, it shows up the screen with a white background and a big Nvidia logo in the center with the warning test key is used.
Failed to validate rootfs status: Load Error
L4TLauncher: Attempting GRUB Boot
L4TLauncher: Attempting Direct Boot
EFI stub: Booting Linux Kernel…
EFI stub: Using DTB from configuration table
EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID devices path
EFI stub: Exiting boot services and installing virtual address map…

Then at the bottom, a progress bar is there with the line at its top that says Press ESCAPE for boot options.

Though the keyboard keys don’t work at all.

After this window, a black background window appears, with information regarding the boot being there.

Last two lines being
[OK] Finished nvpmodel service.
[OK] Finished Configure USB flashing port for device mode.

Then the Jetson doesn’t actually boot up but repeats the same thing as described above endlessly.

I wanted to install CUDA drivers on the Jetson Ubuntu for which I used the NVIDIA SDK Manager. Initially, the Jetson was working fine without any boot issues. For installing the CUDA and SDK components, flashing is to be performed beforehand. After the flashing was done successfully with several of the SDK components also installed but eventually giving ‘apt-get missing dependencies’ error.
After this flashing, the Jetson booted up normally again.
I tried just flashing the Jetson Linux again without the installing SDK components with success but Jetson still won’t boot up to normalcy.
Please help.

Hi dhillondheeraj84,

What’s your current Jetpack version in use?

Could you help to provide the serial console log while you hit the boot up issue?
Jetson Style - Serial Console - JetsonHacks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.