NVIDIA materials failing to render

Hello,

I am unable to get any NVIDIA materials to show up in the viewer. If I open a usd scene exported from blender the BSDF materials show up properly in the viewer and are defined fully as PBR type materials in the usda file.
My testing process:

  1. Start new project in Omniverse Code
  2. Create Cube
  3. Drag material from materials tab onto Cube
  4. Cube stays white. Properties show it has the material assigned.
  5. Changing render mode does not make a difference.
    Additional Test:
  6. Create Material > OmniSurface
  7. Adjust material color with color picker
  8. Drag material onto cube
  9. material updates in properties of cube but remains white in viewer

I noticed in the .usda text view that the NVIDIA materials are described as follows:

def Material “Bamboo”
{
token outputs:mdl:displacement.connect = </World/Looks/Bamboo/Shader.outputs:out>
token outputs:mdl:surface.connect = </World/Looks/Bamboo/Shader.outputs:out>
token outputs:mdl:volume.connect = </World/Looks/Bamboo/Shader.outputs:out>

        def Shader "Shader"
        {
            uniform token info:implementationSource = "sourceAsset"
            uniform asset info:mdl:sourceAsset = @http://omniverse-content-production.s3-us-west-2.amazonaws.com/Materials/Base/Wood/Bamboo.mdl@
            uniform token info:mdl:sourceAsset:subIdentifier = "Bamboo"
            token outputs:out
        }

Some thoughts:
Do I need to have a live link to pull materials from AWS?
Or possibly download an additional content package?
Is it possible to see these default materials with all of their material properties exposed in the usda file?

Thank you for any help!
DAT

Hello @john172! What is your current system environment? Operating System, GPU / GPU Driver?

Hi Wendy!

Thanks for asking.

Windows 10 Professional
Dual A6000 with NvidiaLink
and the recommended driver for Omniverse Code, can’t think of it off hand and stepped away from that computer at the moment. 470.41 maybe?

Thanks @john172! I’ll forward this over to the team for some help! I’ll post back when I have more information.

A small update for debugging - If the NVIDIA materials are placed in Omniverse Code on the default cube or placed on our USD model brought in from Blender, they still do not show up in the render view of Code, but they do show up in Kaolin when brought in through setting the root directory to the saved usd file from Code.

Hi @john172! Short update. The development team is looking into the material library to see if it is accessible in Code.

1 Like