Nvros error on target pc

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
[o] DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[o] Linux

Hardware Platform
[o] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version
[o] 1.9.10816

Host Machine Version
[o] native Ubuntu 18.04


Now I want to run nvros by referring to the nvros document.
I ran the command in the picture below, but it didn’t work.

And I faced the following error.

What’s the problem??
Please help.

Dear @rlfxogud961,
We are checking internally on this issue, Nvros error on target pc and update you.

hello. I would appreciate it if you could give me a solution as quickly as possible.

Dear @rlfxogud961,
The issue indicates the system is not getting any image input from the camera.
Could you confirm if you have connected supported sensor from DRIVE Ecosystem - Hardware and Software | NVIDIA Developer and able to get camera frame using NvMedia SIPL sample.

Thank you for the reply.

The camera operation was confirmed by installing Drivework4.0 on the current Driveos 5.2.6. When sample_camera of Driveworks4.0 is executed, the camera is output. Should the camera be output from NvMedia SIPL sample rather than Driveworks?

Dear @rlfxogud961,
Please check with SIPL camera sample also for confirmation.
Do you notice this issue in every run? May I know the camera module?

How can I run the SIPL camera sample? I don’t know where the executable file is located.

And I am using a gmsl camera model sf3324, and when I run driveworks, it works normally with the camera_type parameter set to “ar0231-rccb-bae-sf3324”.

The error keeps appearing when running.

Dear @rlfxogud961,
I tested the app on my target with S3324 camera connected at A0 port. I notice below output. I don’t see any errors as above.

Terminal 1

nvidia@tegra-ubuntu:/opt/nvidia/nvros/install_isolated$ source setup.bash
nvidia@tegra-ubuntu:/opt/nvidia/nvros/install_isolated$ roscore &
[2] 7293
[1] Exit 127 rosscore
nvidia@tegra-ubuntu:/opt/nvidia/nvros/install_isolated$ … logging to /home/nvidia/.ros/log/aa0cdb2e-6af9-11ed-90d9-00044baf7a32/roslaunch-tegra-ubuntu-7293.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.
started roslaunch server http://tegra-ubuntu:35333/
ros_comm version 1.14.3

  • /rosdistro: melodic
  • /rosversion: 1.14.3

auto-starting new master
process[master]: started with pid [7304]
setting /run_id to aa0cdb2e-6af9-11ed-90d9-00044baf7a32
process[rosout-1]: started with pid [7315]
started core service [/rosout]
nvidia@tegra-ubuntu:/opt/nvidia/nvros/install_isolated$ cd bin
nvidia@tegra-ubuntu:/opt/nvidia/nvros/install_isolated/bin$ ./test_nvros_egl_utils_consumer -d 0 -w 0 -s /tmp/nvros_cam_0
[ INFO] [1669192305.396449168]: Display Id : 0
[ INFO] [1669192305.396687056]: Window Id : 0
[ INFO] [1669192305.396717040]: EGLStream socket_path : /tmp/nvros_cam_0
[ INFO] [1669192305.438998448]: EGLStreamSendfd: sock_fd: 21
[ INFO] [1669192305.441244752]: Waiting for EGL stream producer
[ INFO] [1669192307.442016784]: EGL Stream consumer - Latency: 16000 usec
[ INFO] [1669192307.442130544]: EGL Stream consumer - Timeout: 16000 usec `

Terminal 2

nvidia@tegra-ubuntu:/opt/nvidia/nvros/install_isolated$ source setup.bash
nvidia@tegra-ubuntu:/opt/nvidia/nvros/install_isolated$ cd bin/
nvidia@tegra-ubuntu:/opt/nvidia/nvros/install_isolated/bin$ ./test_nvros_sipl
[ INFO] [1669192307.365777328]: EGLStreamReceivefd: listen_fd: 16
MAX96712: Revision 2 detected
MAX96712: Enable periodic AEQ on Link 0
MAX96705: Pre-emphasis set to 0xaa
MAX96705: Revision 1 detected!
Sensor AR0231 RCCB Rev7 detected!
Module_id 22 Severity 6 : NvMediaICPCreateEx 76
Module_id 22 Severity 6 : T19x VI version 0x000019

Can you tell me what could be the cause of that error? I am in an unresolved state.

Dear @rlfxogud961,
Is other applications working which does not require live camera data.

no… Only camera operation commands are executed.

Dear @rlfxogud961,
Could you check running NvMedia’s nvsipl_camera sample to confirm if no issue with camera connection. Also, please run other sample to see if it is issue with only this sample or NvROS/system setup.
Please check https://docs.nvidia.com/drive/drive-os-