Entron camera bringup issue at Pegasus development kit

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.9.1.10844
other

Host Machine Version
native Ubuntu 18.04
other

My target has drive OS 5.1.5
I am using the NVIDIA ecosystem camera(8MP) from supplier Entron
By following the instruction to put 2 libraries under /usr/lib/nvispl_drv

1)I tried the sample under driveworks(2.2) to run gmsl camera,the bringup is failed with log info on mismatch on resolution, it seems that I need to change the sample code to match it ?

2)It was also told to use ./nvsipl_camera -c “entron_camera_type” -m … , but I can’t find this command nvsipl_camera, is it to be installed with SDK manager?

Dear @tingguang.wang1,
It will be available on host. You need to cross compile NvMedia samples for target. Please find NvMedia samples under /path/to/drive-t186ref-linux/samples. You may search for nvsipl_camera on host .
Please see https://docs.nvidia.com/drive/drive-os-5.2.6.0L/drive-os/index.html#page/DRIVE_OS_Linux_SDK_NGC_Development_Guide/NvMedia/nvmedia_building_running.html# for building NvMedia samples.

with software10 rev2 on host, drive os5.1.6 on target, which step should I start first? this instruction is based on 5.2.6

I guess the /path/to/
is
/home/…/nvidia/nvidia_sdk/DRIVE_Software_10.0_Linux_OS_DRIVE_AGX_PEGASUS_XT/DRIVEOS

Yes. Do you see drive-t186ref-linux/samples under it?

Yes, I have succeed compiled nvsipl,
And I am using a Entron 8MP camera with type F008A070RM0A
After running nvsipl_camera with specified camera name F008A120BMA…(which is not matched to actual camera I am using),
I got some parse error like below
Though this is a Entron RGGB camera which is supposed to used with drive OS 5.2.6, but supplier told it should be fine to use based on their earlier experience, can you check if the error comes from the missing part of nvstream tool or camera type match itself?
BTW, what does it means failed to find matching module MAX96712TPG

Can you provide some feedbacks?

I also tested with Drive development kit default camera, same error is also there, even after I changed parameters. I don’t think the errors come from camera side .

Thanks you!

Hello,

I find the cause:

it says the SDK support only version 1.2 and 2.0 for CMOS AR0820
but the 2.1 is detected with current camera

Is NVIDIA publishes the supporting release matrices btw the driveos version and the camera sample version(CMOS if necessary)?

It’s very weird that even camera supplier doesn’t know this.

Dear @tingguang.wang1,
Good to see you could bring up your camera on DRIVE SW 10.0. Did you get the NITO files from vendor?
Note that we have tested only AR0234,Ar0144 camera modules on DRIVE SW 10.0. (See /path/to/DRIVE_SW_10.0_References/DRIVE_Software/index.html#page/DRIVE_OS_Linux_SDK_Development_Guide/NvMedia/nvmedia_nvsipl_camera.html#wwpID0EVHA)

Could you point me to this in DRIVE SW 10.0 documentation.

I got this log info after runnning nvmedia NVSIPL , not in documentation