Omnigraph / Action Graph: can't seem to make an double3 array with *Make Array*

Hello there,
so I am fiddeling around with action graphs and I just can’t get one particular thing to work:
I want to use the Draw Debug Curve Node to draw a Triangle, giving it the demanded points as an array of double3 values. However, no matter what (variable or constant double3) I feed into the Make Array Node it claims to detect an input of type unknown.

Does anyone have any ideas ?
Thank you in advance.


I was able to get this working on our release build in Windows 10

There were a couple of hiccups though. specifically, when you setup the Make Array node, you need to set the type to double[3][] and then press the little + button in the lower right corner of the inputs panel of the properties pane for the node to add more entries. The total entries after you do this wont be correct though as it seems to index by zero (should be 1 for a non empty size_t). I was also able to get Draw Debug Curve to work ask well, but I had to set the color to something other than zeros (black). If you want a triangle, you will need 4 points in your array, where the last point is just a repeat of the first.

What version of Isaac Sim are you using? What OS are you working with?

Thanks for the help !

I seems like I couldn’t get the triangle to draw for a combination of two reasons:

  • got confused as to how the arraySize attribute worked, since the default is 0 with one input showing and set it incorrectly (now having three input I set it to 3)

  • giving variables new values at runtime via the entire graph’s property panel doesn’t seem to work, so it always drew with the default values 0.0 (changing default values to something different worked)

I have noticed however that if I pause or stop the simulation and change the inputs on the Make Array node from variables of type double3 to constant double3 and vice versa, the errormessage still shows until I press play.

Here’s a screenshot showing the runtime values for the variables set do something different than the defaults and printing the actually used values (which are identical to the defaults):

I am using Isaac Sim 2022.2.0 on Ubuntu 22.04

1 Like

I think this is because the graph gets reevaluated when you hit play, but I am not sure. Is this still causing you issues? sorry for the late reply

I haven’t used the Make Array node since, but the updating a graph’s variable values at runtime externally is a persisting issue. In a different project I’ve managed to change a Graph’s boolean variables from another Graph using a write Prim Attribute node in the latter, but it didn’t work for tokens. Changin values via the UI property window of the Graphs doesn’t work either.

Is this something I should maybe open a new thread about?

yes please do! I will direct some attention to this internally as well

1 Like