Orin nx8g flash

orin nx8g + 32GB external storage ,Is that gonna burn the system? Is there enough storage?

Moving this topic to the Jetson Section for better visibility.

The 64GB or bigger one is recommanded.

  1. What are the reasons for using more than 64GB of storage? 2. Can storage 32G be used? If so, how to burn the system?

Theoretically, 32GB should also work, and please try with SDK Manager.

flash_1-4.2_0_20230809-143658.log (7.7 KB)

The refresh log of sdk manager indicates that the refresh failed。


Please attach the storage device and run this command to know the sector size

sudo fdisk -l /dev/sda

and set the environment variable EXT_NUM_SECTORS with the sector size you just get and manually flash again.

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device sda1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
  --showlogs --network usb0 jetson-orin-nano-devkit internal

EXT_NUM_SECTORS Where is this parameter set?

You just set it in terminal like EXT_NUM_SECTORS=xxxxxxxx, and verify it with echo $EXT_NUM_SECTORS.
Use the same terminal tab to flash the device.

Do I need to restore it after setting? What will be the effect of not restoring?

You just close the terminal tab and it’s gone.

Should the storage of this command be followed by the -S storage size?

I think it’s not needed.
It should by default use all the space available.

Direct EXT_NUM_SECTORS= Storage sector size when executing the refresh command you gave?

Yes, set this variable before flashing.

OK, I’ll try later

flash_1- (7.7 KB)
Tried and failed

What do you got with EXT_NUM_SECTORS?
If it still does not work, please just use storage devices that are 64GB or larger.

It’s got to change. l4t… The NUM_SECTORS parameter in xml,EXT_NUM_SECTORS=60620800

Set EXT_NUM_SECTORS=60620800 or do you want to leave ext out? NUM_SECTORS=60620800?