Permission denied error when run the deepstream-test1

when I run the deepstream-test1,it met an error such as:
tesco-yu@tescoyu-desktop:~$ cd /opt/nvidia/deepstream/deepstream-5.1/sources/apps/sample_apps/deepstream-test1
tesco-yu@tescoyu-desktop:/opt/nvidia/deepstream/deepstream-5.1/sources/apps/sample_apps/deepstream-test1$ ls
deepstream_test1_app.c dstest1_pgie_config.txt Makefile README
tesco-yu@tescoyu-desktop:/opt/nvidia/deepstream/deepstream-5.1/sources/apps/sample_apps/deepstream-test1$ make
cc -c -o deepstream_test1_app.o -DPLATFORM_TEGRA -I…/…/…/includes -I /usr/local/cuda-10.2/include -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib/aarch64-linux-gnu/glib-2.0/include deepstream_test1_app.c
Assembler messages:
Fatal error: can’t create deepstream_test1_app.o: Permission denied
Makefile:63: recipe for target ‘deepstream_test1_app.o’ failed
make: *** [deepstream_test1_app.o] Error 1
how to solve it,thanks a lot!

A regular user does not have permissions to write to content under most system directories. “/opt” is one such location. You could use “sudo” to run the commands, but if possible (to avoid the pitfalls of messing up a system directory) you might first try compiling as your regular user in an alternate location. In the case of the sample apps though I already know the content is not going to interfere, so you might as well just use sudo for the case of the deepstream sample (I would not suggest this with most builds, deepstream sample is an exception).

Thanks for your quick response,I have solved the error when I run the command “sudo CUDA_VER=10.2 make”.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.