PhysX error: Illegal BroadPhaseUpdateData

Hi, I am trying to run a self-designed robot with Orbit Framewok, and I keep having the following questions:

And as shown in the figure, it says, Invalid PhysX transform detected for “/World/Robot_1/logRobotDual/F_L_Lifting”, which is every coordinate in the USD, as shown in the following figure:

I have no idea which part is wrong, and many thanks for any advice and help!

Many thanks for any suggestions, and happy for any discussion!

Hi,
this usually means that the simulation is not stable and the rigid bodies endup with NaN in transformation.
You can try to simulate on CPU to see if CPU handles the simulation better (Window->Simulation->Debug - override the simulation between CPU/GPU). You can also try different solvers TGS/PGS.
You can also try to increase the simulation frequency on PhysicsScene prim.
If all fails, feel free to share the asset if you can we can try to take a look what the problem might be and suggest solution.
Regards,
Ales

Dear @AlesBorovicka , thank you so much for your reply! I tried ur solutions - different combination between GPU/CPU settings and solver type. It does not, and I am glad to share the asset to you, could you please tell me how can I share it to you? By mail or any other ways?

You can send it to me through a personal message here through the forum, we will take a look.

Regards,
Ales

Hi @jianlin_wang_lynn and @AlesBorovicka,

Could you provide some updates on this matter? I’m facing a similar problem when using an imported humanoid robot. I’ve tried the suggestions, such as adjusting CPU/GPU settings, trying different solver types, and increasing the physics scene frequency but without any success.

Interestingly, the same URDF imports successfully in the 2022.2.1 version of Isaac Sim and the simulation runs without reporting the PhysX error. However, when loading the generated USD model into the latest release (2023.1.1), the collider meshes are displaced and various other issues occur.

I’m curious if there are any developments on this problem, or should I proceed with addressing the broken USD model from the previous release?

Thanks!

The USD format did not changed for a while, its probably some simulation difference that is causing issues. We can take a look at the asset if you can share it with us.
Sorry for the trouble.
Regards,
Ales

Hi @ksavevska,

Thanks for the reply and I am off for a while for the robot design and back to the RL now still facing the problem.

I agree with @AlesBorovicka on this problem; if we start directly from omniverse-lanuch, it works fine. For omniverse gym, it still does not work, and I have no idea how to change that. Please tell me if you have any clues.

Jianlin

Looking at the provided asset there are some differences with the importer. In the latest importer it also imports tendons, those actually do break the simulation. They were missing in previous version. Not sure if the import settings changed, but thats the difference.

Ales