Problem with Nucleus and data sharing

I have a problem with Nucleus and data sharing.
I done it by following the link below.

After accessing localhost:8080, I add a user to the group in user management and send them an invite link, but my friends can’t open the file. I open the link and they put in their password and nothing changes.

I have server sharing turned on.
Even if I add folder permissions to them, they can’t see the folder.

Is this a service for people who are on the same server?
If I want to access it from different servers, do I need to create a server before I can share it?
Also, do I need to add anything to the connections in omniverse system moniter > setting?

Thank you for your help!
I don’t have much knowledge about networking, so sorry if I’m asking a weird question.

Steps are typically,

Install Nucleus
Enable Sharing
Create an account for the user and share the reset password link
Get your IP from the machine (whatismyip.com)
Give the server address to to the user you want to share yourip:8080

Often your IP is blocked by your router, you’ll have to open that port on your router in many cases.

Omniverse Setup to Unreal Live Sync
[https://youtu.be/8XdgSwNyVT4]

3 Likes

Are there any other ports that should be open besides 8080?

8080 is for the web view. The Nucleus port defaults to 3009.

2 Likes

Thank you, guys.
I followed the instructions. but I can see an error:
“Failed to connect to the server.” ;_;
Even though the port on router had been opened.

I’m ganna wait for your youtube video, outdoorliving3d.
Thanks!!!

In the Add connection window that pops up when I click the Add button, do I enter the global IP of the connection destination in the “Type Server Name” field and press NEXT to proceed to the login screen?
I get the message “Failed to connect to the server” and cannot proceed to the login screen…

Need to verify all the port listed in the link below are open.
May need to check windows firewall settings.

Thank you everyone for responding!

Based on your advice, I opened up all the ports listed in the “Configuration And Ports” section of the documentation and added all the Omniverse services to the Allowed apps in the firewall settings, but it didn’t work.

I’ve also enabled Server Sharing and created an account.

Is there something else I’m missing?

@ryuichi11100 -
Can you share your network setup in general terms? Both computers on same private network?, Using some cloud based instance for Nucleus server? Basically network topology, Any information would be helpful.

You saw the video? Did that help?

Hi aiaia, are you generating the invite/file URL from within localhost:8080?

If so, connect to :8080 in a web browser and then generate the invite/file URL. Try sharing that URL instead.

Also another thing to check, is the user able to ping your server’s IP address?

We’ve had issues like this come up in the past. It’s a known issue (OM-19781).

There’s a short blurb about this issue + a workaround in the docs, under “Known Issues”. It is under the User Management article, but this issue will occur for any URL generated in Nucleus Web connected to localhost.