Problems connecting Continental ARS430RDI radar to Drive AGX Pegasus

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.9.1.10844
other

Host Machine Version
native Ubuntu 18.04
other

I’m trying to interface the radar (Continental ARS430RDI) with an Nvidia Drive AGX Pegasus. The radar was connected via GMSL cable to the AGX (Pin 1: BR-, Pin 5: BR+ of the radar). Power is provided via a benchtop power supply set to 12V. The cable interfaces via HSD port of the AGX with pins #1 and #3 as you can see below.

I’ve confirmed that I’m seeing data packets with wireshark on a windows laptop (radar ip 192.168.3.33 and port 31122, dest. 239.192.22.10) when connecting through E3579 dongle converting BR to Ethernet. That being said, I wasn’t able to ping the radar once connected to the AGX. I’m trying to display data of the radar using radar_replay_sample (DriveWorks SDK Reference: Radar Replay Sample).

Have you encountered similar connectivity problems with the ARS430RDI before? What debugging steps have you tried?
I’ve followed those threads :

Thanks for your help

Dear @jean-gabriel.mercier,
Could you please all connection pictures and network file changes/commands you have used. Also, please share the ifconfig output.

Here’s my ifconfig output.
Pictures will follow (since i can only post one) of the radar harness (the upper twisted pair, pins 1 and 5, are going to the AGX, the left twisted pair is 12V and GND, finally the tapped leads are unused pins).
I’ve checked with Continental and they’ve confirmed the wiring.
I can confirm that I’m sseing packets in the configuration :
Radar – (BR+/-) → E3579 dongle – (Ethernet) → Windows Laptop.
Now I’m trying :
Radar – (BR+/-) → AGX
But I can’t see the radar on the network (I’m using port 3/4 1GbE/100MbE shown in the picture).

To my knowledge no material changes to the network file has been done.
Those are the commands i’ve tested:
sudo ifconfig eth0:900 192.168.3.81 || true
sudo route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0:900 || true
sudo route add -net 192.168.3.0 netmask 255.255.255.0 dev eth0:900 || true
./sample_radar_replay --protocol=radar.socket --params=device= * CONTINENTAL_ARS430_RDI_V2,ip=192.168.3.33,port=31122
I’ve also tried with multicast-ip parameter with different combinations based on Network configuration for Conti ARS430 - #6 by SivaRamaKrishnaNV.

I’ve also tried:
sudo ip route add 192.168.3.33 via 192.168.3.81 dev eth0:900
and ensured ip forwarding was on. I made sure no firewall rules were blocking traffic on eth0:900.

We’re using Driveworks-4.0 and radar ARS430RDI_V2 with firmware 3.0.0.

Thank you!


Radar harness


Connections to AGX : second connector from left (port 3/4 on left side).

Dear @jean-gabriel.mercier,
could you share the log of sample_radar_replay as well? Also, does changing to other 100Mbps port helps?

I’ve tried every BR ports without any luck…
I’ve ran the replay of the data using protocol=radar.virtual which worked find as expected.
But when trying to visualize a live feed of the radar data using protocol=radar.socket, a window opens but closes immediately with the following error log.
Note that the example using radar.virtual says explicitely firmware 2.0.1 whereas the ARS430RDI_V2 we have is firmware 3.0.0 (confirmed by Continental).

Also, the routing table according to ip route show is:
default dev enp4s0 proto static scope link metric 2048
10.42.0.0/24 dev eth0:200 proto kernel scope link src 10.42.0.28
169.254.0.0/16 dev enp4s0 proto kernel scope link src 169.254.28.172
192.168.3.0/24 dev eth0 proto kernel scope link src 192.168.3.81

Dear @jean-gabriel.mercier,
radar does not response to ping request. Before connecting radar, Could you check connecting to laptop to confirm if the network settings are correct? Is there any router involved in the connection?

reboot the target and run the network settings again.

Also, Can you try using sudo route add -net <RADAR IP> netmask 255.255.255.0 dev eth0:900 || true instead of above setting and let us know if it works?