Re-ordering xform ops

Hey hey,

Is it possible to re-order the transform operation order in create?

In Solaris for instance you could edit properties; and adjust the xformOpOrder -

xformOp:transform, xformOp:translate:move, xformOp:transform1, etc…

I’ve come across some (frustratingly difficult to re-produce) issues where the opOrder has caused problems with the camera in Create that don’t happen in Solaris or Unreal, and it appears to be linked to this.


Hey @dbr - thanks for posting this wonderful question and/or feature request! Checking with the dev team now!

By the way, GTC Spring 2022 has been announced, is all virtual, and free! To register and receive the latest news: GTC 2022: #1 AI Conference

Join us! :)


P.S. The Omniverse documentation site has more info and links to all tutorial videos (under the “Learning and Feedback” category on left nav bar): Omniverse Platform Overview — Omniverse Developer documentation

he / him | LinkedIn | Discord ID: Prof E#2041
Omniverse: “A New Era of Collaboration and Simulation” (video)
Omniverse Create’s latest features show & tell: Twitch livestream.
As seen in VentureBeat | Physics Showcase

Omniverse Resources:
Omniverse | Documentation | Tech Requirements | Videos | Roadmap | Twitter | Discord | Twitch

PLEASE NOTE: If you are reporting a bug/issue, please provide OS, GPU, GPU Driver, the version of the app, and full log file (if applicable). For crashes, please zip and provide a link to your logs → C:\Users\ [YOUR NAME] \ .nvidia-omniverse\logs

1 Like

@dbr you can re-order Transform’s order though not that elegant. The transforms are actually executed in order. In the example you present, the Translate:move is below a black line. It means that although there is an attribute Translate:move, it is NOT activated in the transformation chain. If you right-click its label, you will see a context menu, choose Enable to add it to the bottom of the Transform section, which means that it is activated. If you right-click either of the Transform or Transform:xform1 label, and choose Disable context menu, they will be placed under the black line and thus deactivated. By using the Enable and Disable against different xform ops, you should be able to reorder the xform ops. Note: these reoder operations are undoable.

Thanks for this!

I managed to get around some of the issues with enabling and disabling in the past, but actually re-ordering them would really help as they do create a different result depending on the order. I’m not 100% sure where those orders are going haywire to begin with though which is a big part of the problem!

Thanks again,