Restore Jetson AGX from image

I took backup of AXG using below command

sudo echo "u" | sudo dd of=/proc/sysrq-trigger
sudo dd if=/dev/mmcblk0p1 | ssh ubu@ dd of=/home/user/xavier-image.raw

For restoring I needed, since my host machine was fresh ubuntu 18, I didn’t had any previous files which were used to flash AGX. So I had to install SDK manager on host machine. I was still missing, so I had to flash AGX with JETPACK 4.5.1 from SDK manager. After installing JETPACK on AGX, I had all the files which I need to restore my backup image file.

I used below command to restore my backup image. I don’t know exactly which OS my backup image is, but surely it can’t be JETPACK 4.5.1. I had my old AGX flashed more than 1 year ago.

cd /home/nvidia/Downloads/Xavier/Linux_for_Tegra
ln -s /home/user/xavier-image.raw bootloader/system.img 
#( I also tried below command to convert raw to img)
# sudo bootloader/mksparse -v --fillpattern=0 /home/user/image.raw /bootloader/system.img
cd /home/nvidia/Downloads/Xavier/Linux_for_Tegra/ 
sudo ./ -r jetson-xavier mmcblk0p1

Flashing was successful, but I don’t see any screen. I have tried different ways disconnecting hdmi before the boot, but still I don’t see my system starting up. I have attached log of flash and boot.

Please help me to restore.

install_log.txt (60.2 KB) boot_log.txt (28.1 KB)

Normally if you have run JetPack/SDKM for some specific model of Jetson (I think you can tell it to download but not flash), then you should have this directory:

That directory contains If you intend to flash from a clone, then that is all you need. If you need the flash software to install a new image which it generates, then you also need the “Linux_for_Tegra/rootfs/” populated and set up for Jetsons. The latter is done automatically if you use JetPack/SDKM, but can also be performed manually.

Your method of dd should work, but it may not be as good as a true clone. I say this because yoru backup will have frozen a running system, and any temporary lock files or other temporary content will be present which should actually not be there during boot. It is unlikely that difference will have any significant impact, but you should be aware that some cached or temporary content which would have been removed from a clean reboot will exist from the start of first boot with the new image. is capable of cloning over USB using a Jetson in recovery mode, and recovery mode after a clean shutdown is the best backup.

I can’t answer for sure, but it does look like your boot log is missing something. If the backup image was from a different version of JetPack/SDKM, then this might be part of the issue. Be careful to not overwrite your backup, but you might find out what happens if you flash using JetPack/SDKM without using your image. If it then works you can try to restore using your original command line restore (your restore of system.img was valid, but I think something in the surrounding partitions or QSPI memory probably was wrong). As long as you have your backup image you are probably free to test ordinary flash without too much worry.