ROS2 Nav2 - Navigation not working

Hello !

I am trying to use Nav2 with Isaac Sim as the Simulation software. The navigation stack launch properly but the robot is not reaching the goal, even worse it is not really following the path.

[The visualization software used here is Foxglove, exactly the same as Rviz]

All the pictures show the final state of the robot. And as showed, the robot’s planned path (in purple) is correct but the real path (red dots) is not. It almost looks like the robot is trying really hard to reach the goal but with a poor accuracy.
On the other hand the Isaac Sim navigation example works really well so my guess would be that the Nav2 side is working well.

During my experiments, I have tried with both 4 and 2 wheels robots (I would like to use 4 wheels robots but as it did not work I tried with two wheels) but none of them work as intended.

My guess would be that the friction between the wheels and the ground is incorrect or that I used wrong parameters during the robot assembly.

Physic material for the wheels:

The 2 wheels robot

The 4 wheels robot

Please also find enclosed the usd file for both robots, the environment and the used sensor:

Loe_revor.usd (71.4 KB)
2d_lidar.usd (15.9 KB)
onion_revor.usd (162.4 KB)
indoor.usd (212.3 KB)
loe_2d_lidar.usd (5.5 KB)

The params files used for the SLAM-toolbox and nav2:
mapper_params_online_async.yaml (2.3 KB)
nav2_params.yaml (7.7 KB)

ros2 launch slam_toolbox params_file:=./src/loe_revor/config/slam_toolbox/mapper_params_online_async.yaml use_sim_time:=false

ros2 launch nav2_bringup params_file:=./src/loe_revor/config/nav2/nav2_params.yaml use_sim_time:=false

SLAM: slam-toolbox (with minor changes)
ROS2: foxy and humble (I have tried both)
Isac-sim: 2022.2.1 and 2022.2.0 (I have tried both)
Navigation: nav2 (with minor changes on the parameter file)

Expected behavior:
2023-04-18 11-22-49.mkv (11.5 MB)

Hi @gabriel.garcia - Someone from our team will review and get back to you.

1 Like

Small update the custom two wheels robot is now working, I made it in the wrong direction. However, even with the modification the 4 wheels robot is not working. It is trying to follow the planned path then after 2 seconds it stop and start to rotate then stop and redo the pattern. After some time it stop without reaching the goal.

I am still not 100% sure that it is not Isaac nor Nav2, the 4 wheels could add too much friction for the robot to handle. It’s good to know that the two wheeled robot is working but it’s unfortunate as we are using four wheels.

Hi @gabriel.garcia - Someone from our team will review the issue from the Nav side. Meanwhile, have you tried to adjust the physics parameter? changing it makes any improvement?