Running Replicator Headless Never Runs

I have a script that generates random scenes and saves out data, and this works when run in the Omniverse Code Script Editor. I then tried running it headless, following this tutorial: Running Replicator Headlessly but the command just hangs after the output “RTX Ready”. I am getting the same output as referenced in this other post: Running Replicator Headlessly not working (no output) I also tried just running the example code in the tutorial and end up with the same issue.

I saw the solution was to run with absolute paths, and I am doing that, moving directly into my omniverse code directory and specifying the absolute python filepath. I noticed that if I intentionally misspell the filepath, I get the same output with no errors, only warnings. I tried running without the --no-window flag, and the code window opens up but shows no issues or errors. Here’s my full output:
output (28.3 KB)

Hello @alvinshek99, thank you for reaching out. Looking at the log, am I right in understanding the command run was ./omni.code.sh /home/alvin/isaac_sim/rep_tutorial.py? If so, please try specifying it like this:

./omni.code.sh --/omni/replicator/script=/home/alvin/isaac_sim/rep_tutorial.py