Error when running omniverse-replicator docker container

I’m trying to run omniverse replicator on a GCP Ubuntu VM, since there is no display I’m using the omniverse docker container instead

I started the container using this command

$ docker run --gpus all --entrypoint /bin/bash -it -v $(pwd)/outputs:/_output/

Then install VIM

apt-get update
apt-get install vim

pasted the hello world replicator script

then ran the script using headless mode
./ --allow-root --no-window --/omni/replicator/

Getting the following error after running the script
error.txt (109.4 KB)

Can someone please take a look and suggest a fix to this issue, Thanks

Hi @jordansumitomo can you check out this post here and see if this helps you out? If not, let me know. I responded to you on discord, but doesn’t hurt to answer here as well.

Can you please verify to see if it did produce an output folder? The output folder should have your images. In the case of the container, it can have an unclean exit, yet have successfully made data. We are working on improving the exit.

Hello @pcallender and @nworkerxz9q8 . I tried running the same thing on replicator containers on 2 different PCs(one server and one gaming laptop) and got the same error mentioned by “@ jordansumitomo” both the PCs.
However, I faced a different problem. The Server had an empty output folder but the laptop had the images generated. The errors on both PCs are same as error.txt uploaded already with slight variations.

Can you please share what are your opinions on this and why do I get this error.
My goal is to run the program on better PC(server) but the output is empty there.

Thank you