Shader type in gpu hang is reported as "Internal - Ray Tracing"

Hello there,

We are facing a GPU hang in a Vulkan ray tracing call and the aftermath dump in Nsight shows that most active warps are of “Internal - Ray Tracing” type. Below you can see a screenshot of it, the grey marked lines are resolved shaders.

Any tips on how we can approach this? Thank you!

Thank you for using Nsight Aftermath SDK and sorry you ran into a GPU hang. I’ll connect with the engineering manager of Nsight Aftermath and follow back up with you. In the meantime can you share what GPU you have, what GPU driver version you are on and which Nsight Aftermath SDK version you were using?

Hello and thanks for getting back to me.

My GPU is RTX 2070super, the driver version is 526.98 and the Aftermath SDK version is 2022.2.

Getting back to this, we have found a workaround or a solution to the original problem. Turns out we were submitting too many ray tracing calls inside one command buffer and we were hitting the limit seconds of TdrDelay.

But splitting the calls into different command buffers solved it (or worked around it).

But I would like to know if there is anything that we can do to help debugging when we have such shader list reported.