Startup problem of jetson nano

Hi there,
I’m using 4GB Jetson Nano for the first time. And I have a problem about startup. I watched every video about set the Jetson Nano and I did everything like they did. But my Jetson Nano cant even open the monitor! These are all videos I watched. You can see as below.

I downloaded and set SD Card Formatter and balenaEtcher.

I downloaded the SD Card Image from this site. (JETSON NANO DEVELOPER KIT → For Jetson Nano Developer Kit → Download the SD Card Image)

I formatted the SD card with SD Card Formatter program like how is it explained in this site and in all videos. I wrote the image to SD card with balenaEtcher like how is it explained in this site and in all videos.

I inserted the SD card into Jetson Nano. I connected keyboard and mouse with USB connection and connected the monitor with HDMI.

Lastly, I connected the power connection 5V. Green led was lighting but not constantly. More like toggle. The adapters I use can provide current up to about 5A. So I don’t think it’s because of the adapters.

I waited, almost 1-2 minutes. Monitor didnt open. I checked if monitor power button is clicked but when I clicked the power button of monitor again, screen closed completely. I clicked again and I saw the “POWER SAVING MODE” text on monitor. This means monitor was sleep mode. So, Jetson Nano couldnt open it.

I tried again format the SD card, wrote image. Disconnect all connections apart of HDMI and power. I changed the SD card and I tried again. I tried even supply the voltage with plug type and also micro-usb port.

However, none of them worked.

Please help me.

A precise analysis requires you to dump the log with below method.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.