Stuck at NVIDIA logo and not booting

Hi,

I have Jetson Nano 2gb, I successfully flashed Jetpack 4.6 to SD Card. However, when I power the Jetson it stucks on NVIDIA logo and not booting. I have an another Jetson Nano 2gb which boots successfully same SD card. So I look at the bootloader with minicom. I have some errors and don’t know how to fix it. Here is my minicom log below.

[0000.125] [L4T TegraBoot] (version 00.00.2018.01-l4t-e82258de)
[0000.130] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.138] Power-up reason: pmc por
[0000.141] No Battery Present
[0000.144] pmic max77620 reset reason
[0000.147] pmic max77620 NVERC : 0x40
[0000.151] RamCode = 1
[0000.153] Platform has DDR4 type RAM
[0000.156] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0x606b8
[0000.172] Entering ramdump check
[0000.175] Get RamDumpCarveOut = 0x0
[0000.178] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!
[0000.188] Sdram initialization is successful 
[0000.192] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.198] Lp0 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.204] BpmpFw Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.210] GSC1 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.216] Resize the SecureOs Carveout to 0x00100000
[0000.221] GSC2 Carveout Base=0x00000000ff900000 Size=0x00100000
[0000.226] GSC4 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.232] GSC5 Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.238] GSC3 Carveout Base=0x00000000bf800000 Size=0x00200000
[0000.244] RamDump Carveout Base=0x0000000000000000 Size=0x00000000
[0000.250] Platform-DebugCarveout: 0
[0000.253] Nck Carveout Base=0x00000000ff800000 Size=0x00000000
[0000.259] Non secure mode, and RB not enabled.
[0000.263] BoardID = 3448, SKU = 0x3
[0000.266] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.270] Nano-SD: checking PT table on QSPI ...
[0000.274] Read PT from (2:0)
[0000.290] Using BFS PT to query partitions 
[0000.295] Loading Tboot-CPU binary
[0000.324] Verifying TBC in OdmNonSecureSBK mode
[0000.334] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.341] Bootloader downloaded successfully.
[0000.345] Downloaded Tboot-CPU binary to 0xa0000258
[0000.350] MAX77620_GPIO5 configured
[0000.353] CPU power rail is up
[0000.356] CPU clock enabled
[0000.360] Performing RAM repair
[0000.363] Updating A64 Warmreset Address to 0xa00002e9
[0000.368] BoardID = 3448, SKU = 0x3
[0000.371] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.375] Nano-SD: checking PT table on QSPI ...
[0000.379] Loading NvTbootBootloaderDTB
[0000.446] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode
[0000.519] Bootloader DTB Load Address: 0x83000000
[0000.523] BoardID = 3448, SKU = 0x3
[0000.527] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.530] Nano-SD: checking PT table on QSPI ...
[0000.535] Loading NvTbootKernelDTB
[0000.601] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode
[0000.674] Kernel DTB Load Address: 0x83100000
[0000.678] BoardID = 3448, SKU = 0x3
[0000.681] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.685] Nano-SD: checking PT table on QSPI ...
[0000.691] Loading cboot binary
[0000.807] Verifying EBT in OdmNonSecureSBK mode
[0000.849] Bootloader load address is 0x92c00000, entry address is 0x92c00258
[0000.856] Bootloader downloaded successfully.
[0000.860] BoardID = 3448, SKU = 0x3
[0000.863] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.867] Nano-SD: checking PT table on QSPI ...
[0000.872] PT: Partition NCT NOT found ! 
[0000.875] Warning: Find Partition via PT Failed
[0000.880] Next binary entry address: 0x92c00258 
[0000.884] BoardId: 3448
[0000.889] Overriding pmu board id with proc board id
[0000.894] Display board id is not available 
[0000.898] No Bpmp FW loaded
[0000.900] Not loading WB0 as no bpmp/sc7entry fw
[0000.905] Set NvDecSticky Bits
[0000.908] GSC2 address ff93fffc value c0edbbcc
[0000.915] GSC MC Settings done
[0000.917] BoardID = 3448, SKU = 0x3
[0000.921] QSPI-ONLY: SkipQspiOnlyFlag = 0
[0000.925] Nano-SD: checking PT table on QSPI ...
[0000.930] TOS Image length 53680
[0000.933]  Monitor size 53680
[0000.936]  OS size 0
[0000.951] Secure Os AES-CMAC Verification Success!
[0000.956] TOS image cipher info: plaintext
[0000.959] Loading and Validation of Secure OS Successful
[0000.975] NvTbootPackSdramParams: start. 
[0000.980] NvTbootPackSdramParams: done. 
[0000.984] Tegraboot started after 51844 us
[0000.988] Basic modules init took 908999 us
[0000.992] Sec Bootdevice Read Time = 12 ms, Read Size = 61 KB
[0000.998] Sec Bootdevice Write Time = 0 ms, Write Size = 0 KB
[0001.003] Next stage binary read took 11286 us
[0001.007] Carveout took -63811 us
[0001.011] CPU initialization took 99964 us
[0001.014] Total time taken by TegraBoot 956438 us

[0001.019] Starting CPU & Halting co-processor 

64NOTICE:  BL31: v1.3(release):5b49e7f80
NOTICE:  BL31: Built : 08:37:40, Feb 19 2021
ERROR:   Error initializing runtime service trusty_fast
[0001.141] RamCode = 1
[0001.143] get_emc_table_offset: Can't find emc-table node
[0001.148] LPDDR4 Training: Can't find emc-table node
[0001.184] 
[0001.185] Debug Init done
[0001.187] Marked DTB cacheable
[0001.190] Bootloader DTB loaded at 0x83000000
[0001.195] Marked DTB cacheable
[0001.198] Kernel DTB loaded at 0x83100000
[0001.202] DeviceTree Init done
[0001.215] Pinmux applied successfully
[0001.219] gicd_base: 0x50041000
[0001.223] gicc_base: 0x50042000
[0001.226] Interrupts Init done
[0001.230] Using base:0x60005090 & irq:208 for tick-timer
[0001.235] Using base:0x60005098 for delay-timer
[0001.240] platform_init_timer: DONE
[0001.243] Timer(tick) Init done
[0001.247] osc freq = 38400 khz
[0001.251] 
[0001.252] Welcome to L4T Cboot
[0001.255] 
[0001.256] Cboot Version: 00.00.2018.01-t210-39562017
[0001.261] calling constructors
[0001.264] initializing heap
[0001.266] initializing threads
[0001.269] initializing timers
[0001.272] creating bootstrap completion thread
[0001.277] top of bootstrap2()
[0001.280] CPU: ARM Cortex A57
[0001.282] CPU: MIDR: 0x411FD071, MPIDR: 0x80000000
[0001.287] initializing platform
[0001.295] Manufacturer: MF = 0xc2, ID MSB = 0x25
[0001.299] ID LSB = 0x36, ID-CFI len = 194 bytes
[0001.304] Macronix QSPI chip present
[0001.307] SPI device register
[0001.310] init boot device
[0001.313] allocating memory for boot device(SPI)
[0001.317] registering boot device
[0001.326] QSPI bdev is already initialized
[0001.330] Enable APE clock
[0001.332] Un-powergate APE partition
[0001.336] of_register: registering tegra_udc to of_hal
[0001.341] of_register: registering inv20628-driver to of_hal
[0001.346] of_register: registering ads1015-driver to of_hal
[0001.352] of_register: registering lp8557-bl-driver to of_hal
[0001.358] of_register: registering bq2419x_charger to of_hal
[0001.363] of_register: registering bq27441_fuel_gauge to of_hal
[0001.375] gpio framework initialized
[0001.378] of_register: registering tca9539_gpio to of_hal
[0001.384] of_register: registering tca9539_gpio to of_hal
[0001.389] of_register: registering i2c_bus_driver to of_hal
[0001.395] of_register: registering i2c_bus_driver to of_hal
[0001.400] of_register: registering i2c_bus_driver to of_hal
[0001.406] pmic framework initialized
[0001.409] of_register: registering max77620_pmic to of_hal
[0001.415] regulator framework initialized
[0001.419] of_register: registering tps65132_bl_driver to of_hal
[0001.425] initializing target
[0001.430] gpio_driver_register: register 'tegra_gpio_driver' driver
[0001.439] board ID = D78, board SKU = 3
[0001.442] Skipping Z3!
[0001.447] fixed regulator driver initialized
[0001.465] initializing OF layer
[0001.468] NCK carveout not present
[0001.471] Skipping dts_overrides
[0001.475] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.492] I2C Bus Init done
[0001.495] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.505] I2C Bus Init done
[0001.508] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.518] I2C Bus Init done
[0001.521] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.531] I2C Bus Init done
[0001.534] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.545] I2C Bus Init done
[0001.547] of_children_init: Ops found for compatible string maxim,max77620
[0001.558] max77620_init using irq 118
[0001.562] register 'maxim,max77620' pmic
[0001.567] gpio_driver_register: register 'max77620-gpio' driver
[0001.573] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0001.583] I2C Bus Init done
[0001.587] NCK carveout not present
[0001.597] Find /i2c@7000c000's alias i2c0
[0001.601] get eeprom at 1-a0, size 256, type 0
[0001.610] Find /i2c@7000c500's alias i2c2
[0001.613] get eeprom at 3-a0, size 256, type 0
[0001.618] get eeprom at 3-ae, size 256, type 0
[0001.622] pm_ids_update: Updating 1,a0, size 256, type 0
[0001.628] I2C slave not started
[0001.631] I2C write failed
[0001.633] Writing offset failed
[0001.636] eeprom_init: EEPROM read failed
[0001.640] pm_ids_update: eeprom init failed
[0001.644] pm_ids_update: Updating 3,a0, size 256, type 0
[0001.674] pm_ids_update: The pm board id is 3448-0003-400
[0001.681] Adding plugin-manager/ids/3448-0003-400=/i2c@7000c500:module@0x50
[0001.690] pm_ids_update: pm id update successful
[0001.694] pm_ids_update: Updating 3,ae, size 256, type 0
[0001.724] pm_ids_update: The pm board id is 3542-0000-201
[0001.730] Adding plugin-manager/ids/3542-0000-201=/i2c@7000c500:module@0x57
[0001.738] pm_ids_update: pm id update successful
[0001.769] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0001.775] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0001.782] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0001.788] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0001.797] updating /chosen/nvidia,ethernet-mac node 48:b0:2d:2e:d7:14
[0001.803] Plugin Manager: Parse ODM data 0x000a4000
[0001.815] shim_cmdline_install: /chosen/bootargs: earlycon=uart8250,mmio32,0x70006000 
[0001.830] Find /i2c@7000c000's alias i2c0
[0001.834] get eeprom at 1-a0, size 256, type 0
[0001.843] Find /i2c@7000c500's alias i2c2
[0001.847] get eeprom at 3-a0, size 256, type 0
[0001.851] get eeprom at 3-ae, size 256, type 0
[0001.856] pm_ids_update: Updating 1,a0, size 256, type 0
[0001.861] I2C slave not started
[0001.864] I2C write failed
[0001.867] Writing offset failed
[0001.870] eeprom_init: EEPROM read failed
[0001.874] pm_ids_update: eeprom init failed
[0001.878] pm_ids_update: Updating 3,a0, size 256, type 0
[0001.908] pm_ids_update: The pm board id is 3448-0003-400
[0001.914] Adding plugin-manager/ids/3448-0003-400=/i2c@7000c500:module@0x50
[0001.921] pm_ids_update: pm id update successful
[0001.926] pm_ids_update: Updating 3,ae, size 256, type 0
[0001.956] pm_ids_update: The pm board id is 3542-0000-201
[0001.962] Adding plugin-manager/ids/3542-0000-201=/i2c@7000c500:module@0x57
[0001.969] pm_ids_update: pm id update successful
[0001.999] Add serial number:1424120065503 as DT property
[0002.007] Applying platform configs
[0002.014] platform-init is not present. Skipping
[0002.018] calling apps_init()
[0002.024] Couldn't find GPT header
[0002.029] Proceeding to Cold Boot
[0002.032] starting app android_boot_app
[0002.036] Device state: unlocked
[0002.039] display console init
[0002.047] could not find regulator
[0002.070] hdmi cable not connected
[0002.073] is_hdmi_needed: HDMI not connected, returning false
[0002.079] hdmi is not connected
[0002.086] DT entry for leds-pwm not found
[0002.082] sor0 is not supported
[0002.093] display_console_init: no valid display out_type
[0002.101] subnode volume_up is not found !
[0002.105] subnode back is not found !
[0002.108] subnode volume_down is not found !
[0002.113] subnode menu is not found !
[0002.116] Gpio keyboard init success
[0002.197] found decompressor handler: lz4-legacy
[0002.211] decompressing blob (type 1)...
[0002.276] display_resolution: No display init
[0002.280] Failed to retrieve display resolution
[0002.285] Could not load/initialize BMP blob...ignoring
[0002.360] decompressor handler not found
[0002.363] load_firmware_blob: Firmware blob loaded, entries=2
[0002.369] XUSB blob version 0 size 124416 @ 0x92ca828c
[0002.375] -------> se_aes_verify_sbk_clear: 747
[0002.380] se_aes_verify_sbk_clear: Error
[0002.383] SE operation failed
[0002.386] bl_battery_charging: connected to external power supply
[0002.395] display_console_ioctl: No display init
[0002.400] switch_backlight failed
[0002.406] device_query_partition_size: failed to open partition spiflash0:MSC !
[0002.413] MSC Partition not found
[0002.420] device_query_partition_size: failed to open partition spiflash0:USP !
[0002.427] USP partition read failed!
[0002.431] blob_init: blob-partition USP header read failed
[0002.436] android_boot Unable to update recovery partition
[0002.441] kfs_getpartname: name = LNX
[0002.445] Loading kernel from LNX
[0002.454] Found 19 BFS partitions in "spiflash0"
[0002.773] load kernel from storage
[0002.778] decompressor handler not found
[0003.042] Successfully loaded kernel and ramdisk images
[0003.047] board ID = D78, board SKU = 3
[0003.051] sdmmc node status = okay
[0003.055] sdcard instance = 0
[0003.058] sdcard gpio handle 0x5b
[0003.061] sdcard gpio pin 0xc9
[0003.064] sdcard gpio flags 0x0
[0003.067] vmmc-supply 0x9e
[0003.069] cd_gpio_pin = 201
[0003.072] pin_state = 0
[0003.074] Found sdcard
[0003.077] SD-card IS present ...
[0003.080] load_and_boot_kernel: SD card detected OK
[0003.086] display_resolution: No display init
[0003.090] Failed to retrieve display resolution
[0003.094] bmp blob is not loaded and initialized
[0003.099] Failed to display boot-logo
[0003.102] NCK carveout not present
[0003.106] Skipping dts_overrides
[0003.109] NCK carveout not present
[0003.119] Find /i2c@7000c000's alias i2c0
[0003.123] get eeprom at 1-a0, size 256, type 0
[0003.132] Find /i2c@7000c500's alias i2c2
[0003.135] get eeprom at 3-a0, size 256, type 0
[0003.140] get eeprom at 3-ae, size 256, type 0
[0003.144] pm_ids_update: Updating 1,a0, size 256, type 0
[0003.150] I2C slave not started
[0003.153] I2C write failed
[0003.155] Writing offset failed
[0003.158] eeprom_init: EEPROM read failed
[0003.162] pm_ids_update: eeprom init failed
[0003.166] pm_ids_update: Updating 3,a0, size 256, type 0
[0003.196] pm_ids_update: The pm board id is 3448-0003-400
[0003.203] Adding plugin-manager/ids/3448-0003-400=/i2c@7000c500:module@0x50
[0003.212] pm_ids_update: pm id update successful
[0003.216] pm_ids_update: Updating 3,ae, size 256, type 0
[0003.246] pm_ids_update: The pm board id is 3542-0000-201
[0003.252] Adding plugin-manager/ids/3542-0000-201=/i2c@7000c500:module@0x57
[0003.260] pm_ids_update: pm id update successful
[0003.291] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0003.297] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0003.304] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0003.310] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0003.319] updating /chosen/nvidia,ethernet-mac node 48:b0:2d:2e:d7:14
[0003.325] Plugin Manager: Parse ODM data 0x000a4000
[0003.337] shim_cmdline_install: /chosen/bootargs: earlycon=uart8250,mmio32,0x70006000 
[0003.346] Add serial number:1424120065503 as DT property
[0003.354] Updated bpmp info to DTB
[0003.358] Updated initrd info to DTB
[0003.362] "proc-board" doesn't exist, creating 
[0003.368] Updated board info to DTB
[0003.371] "pmu-board" doesn't exist, creating 
[0003.377] Updated board info to DTB
[0003.381] "display-board" doesn't exist, creating 
[0003.387] Updated board info to DTB
[0003.390] "reset" doesn't exist, creating 
[0003.395] Updated reset info to DTB
[0003.398] display_console_ioctl: No display init
[0003.402] display_console_ioctl: No display init
[0003.407] display_console_ioctl: No display init
[0003.412] Cmdline: tegraid=21.1.2.0.0 ddr_die=2048M@2048M section=256M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvf 
[0003.444] DTB cmdline: earlycon=uart8250,mmio32,0x70006000 
[0003.449] boot image cmdline: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 
[0003.462] Updated bootarg info to DTB
[0003.466] Adding uuid 00000001644612c02400000012fe8380 to DT
[0003.472] Adding eks info 0 to DT
[0003.477] WARNING: Failed to pass NS DRAM ranges to TOS, err: -7
[0003.483] Updated memory info to DTB
[0003.491] set vdd_core voltage to 1125 mv
[0003.495] setting 'vdd-core' regulator to 1125000 micro volts
[0003.501] Found secure-pmc; disable BPMP


U-Boot 2020.04-g6b630d64fd (Feb 19 2021 - 08:37:46 -0800)

SoC: tegra210
Model: NVIDIA Jetson Nano Developer Kit
Board: NVIDIA P3450-0000
DRAM:  2 GiB
MMC:   sdhci@700b0000: 1, sdhci@700b0600: 0
Loading Environment from SPI Flash... SF: Detected mx25u3235f with page size 256 Bytes, erase size 4 KiB, total 4 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   No ethernet found.
Hit any key to stop autoboot:  0 
switch to partitions #0, OK
mmc1 is current device
Scanning mmc 1:1...
Found /boot/extlinux/extlinux.conf
Retrieving file: /boot/extlinux/extlinux.conf
845 bytes read in 28 ms (29.3 KiB/s)
1:      primary kernel
Retrieving file: /boot/initrd
7160133 bytes read in 333 ms (20.5 MiB/s)
Retrieving file: /boot/Image
34484232 bytes read in 1508 ms (21.8 MiB/s)
append: tegraid=21.1.2.0.0 ddr_die=2048M@2048M section=256M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id 
## Flattened Device Tree blob at 83100000
   Booting using the fdt blob at 0x83100000
ERROR: reserving fdt memory region failed (addr=0 size=0)
ERROR: reserving fdt memory region failed (addr=0 size=0)
   Using Device Tree in place at 0000000083100000, end 000000008317e68d
copying carveout for /host1x@50000000/dc@54200000...
copying carveout for /host1x@50000000/dc@54240000...

Starting kernel ...

[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.9.253-tegra (buildbrain@mobile-u64-5496-d5000) (gcc version 7.3.1 20180425 [linaro-7.3-2018.05 revision d29120a421
[    0.000000] Boot CPU: AArch64 Processor [411fd071]
[    0.000000] OF: fdt:memory scan node memory@80000000, reg size 48,
[    0.000000] OF: fdt: - 80000000 ,  3f800000
[    0.000000] OF: fdt: - bfa00000 ,  3fe00000
[    0.000000] OF: fdt: - ffa00000 ,  600000
[    0.000000] earlycon: uart8250 at MMIO32 0x0000000070006000 (options '')
[    0.000000] bootconsole [uart8250] enabled


There might be something else wrong, but do beware that most of the boot content is not on the SD card…most (or all in recent releases) of the boot content is on the QSPI memory of the Nano itself. That software must be compatible in release version with the SD card’s content. The next step, even if this does turn out to be some other failure, would be to flash the Nano itself (which would update QSPI). Since your SD card is from JetPack 4.6, then you’d flash the non-working unit (not the SD card) with JetPack 4.6. After that it might just work with the 4.6 SD card.

I have successfully booted after flashing Jetpack with the SDK Manager. The porblem was probably as you stated @linuxdev. It looks like the bootloader was for the jetson nano not for the 2gb kit. Also it could be something else don’t know.

Model: NVIDIA Jetson Nano Developer Kit
Board: NVIDIA P3450-0000
DRAM:  2 GiB

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.