Switch between DriveSoftware 10.0 and DriveOS 5.2.x

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

First, we have DriveSoftware 10.0 installed for the basic verification and testing, which goes smoothly for OS/DL/LiDAR applications, as well as the IPC communication between XavierA and XavierB.

Secondly on the same host, we installed DriveOS 5.2.0 using the same SDK Manager to flash XavierB to DriveOS 5.2.0 (keep XavierA still at DriveSoftware 10 as reference), and then we see those display, network, tensorRT… which are not included, and other issues. Also tried 5.2.6 and see the similar issues as 5.2.0.

Thirdly we decided to switch back to DriveSoftware 10.0 on the same host to re-flash XavierB (XavierA has 10.0 w/o changing) and see many errors in SDK manager:

Tried sudo -S apt-get update && sudo -S apt-get check; sudo apt --fix-broken install and it keeps showing:

Then tried to re-install and repair which doesn’t help, also uninstall everything → reboot host → restart SDK Manager for DriveSoftware 10.0 and still see above failures.

Is there a way to do a complete cleanup for previous DriveSoftware/DriveOS’s installation, either through SDK Manager or not, so that we can restart SDK Manager for a new/fresh/clean DriveSoftware/DriveOS installation? Does the installation through SDK Manager available inside docker/container or other isolation approach without affecting the Host environment?

Hi, @hfkou

Did you mean you tried 2. Repair and Uninstall and it didn’t help?
Could you share your ~/.nvsdkm logs?

log.tar.gz (2.0 MB)
yes, we tried that repair and uninstall, log is attached.

Just in case, the system dependencies enter into certain conflict mode… is there a way to clean it up, either through SDK Manager or not, to recover the host system to support the new SDK installation for DriveOS/DriveSoftware?

Good question. Before looking into your logs, please try if the solution in Error while installing DriveOS 5.2.0 from SDK Manager 1.6.1 helps.

Here is the output for that big purge and “sudo -S apt-get update && sudo -S apt-get check; sudo apt --fix-broken install”
purge-log.txt (34.0 KB)

Then, tried DriveSoftware 10 installation using SDK Manager
log-110221.tar.gz (2.3 MB)

Does DriveOS/DriveSoftware installation through SDK Manager support any docker/container or other isolation approaches, so that it doesn’t affect the Host environment, also users can have different versions of DriveOS/DriveSoftware installed on the same host without conflicting with each other as well as the Host?

If DRIVE OS 5.2.6 is still an option to you, you can try with Install DRIVE Docker Containers from NVIDIA GPU Cloud (NGC).

Please try with removing custom sources in /etc/apt/sources.list.d/ first.

Do you mean rm -rf /etc/apt/sources.list.d/* ?

When switching between DriveSoftware 10.0 and DriveOS 5.2.x, should we always use the Nsight comes inside each DriveSoftware/DriveOS packages, for example:

  • Nsight 2019.3.4.11: DriveSoftware 10.0
  • Nsight 2020.2: DriveOS 5.2.0
  • Nsight 2021.1: DriveOS 5.2.6

Or the latest Nsight 2021.4.1.73 works for all different versions of DriveSoftware/DriveOS?

Yes, if you want, you can back up it before removing it.

The version installed along with was verified. You can always start from it as a baseline.

For DriveSoftware 10.0, its default Nsight 2019.3.4 on Linux works, but I want to profile from Macbook, so download Nsight 2019.3.6 & 2019.3.6 for Mac and it shows “Communication Error”, while network is verified known good.

Then, tried latest 2021.4.1 and it shows “Target is not support”

Missing directory with target binaries: /Applications/NVIDIA Nsight Systems.app/Contents/target-linux-tegra-armv8

DirectoryNotFoundError (150) {
OriginalExceptionClass: N5boost16exception_detail10clone_implIN11QuadDCommon26DirectoryNotFoundExceptionEEE
OriginalFile: /Users/devtools/buildAgent/work/20a3cfcd1c25021d/QuadD/Host/Analysis/PosixDeviceValidator.cpp
OriginalLine: 26
OriginalFunction: bool QuadDAnalysis::PosixDeviceValidator::CheckHostSupport(const QuadDAnalysis::DevicePtr &)
Filename: /Applications/NVIDIA Nsight Systems.app/Contents/target-linux-tegra-armv8
ErrorText: Deploy directory does not exist

Only find target-linux-sbsa-armv8 & target-linux-x64 under /Applications/NVIDIA Nsight Systems.app/Contents/target-linux-*

Although I doubt we can support this, please still create another topic for this. Thanks.

Is your DRIVE OS 5.2.6 installation problem solved?

We stay on DriveSoftware 10 for now, 5.2.x has so many issues… and not completely ready.
Will there be DriveSoftware 11 to be released sometime this year?

There is no DRIVE Software 11.
Below is from “5.2.6” section in NVIDIA DRIVE Downloads | NVIDIA Developer.


Nsight Systems version installed by SDK Manager is the only version verified and supported.

If you have further questions about Nsight Systems, please create another topic. Let’s not clutter things in the topic. Thanks.