The board can not bootup when setting uphy to config#3 in Jetpack 5.0.1

Hi, Nvidia teams:
According your guide , I set uphy to config #3 by modify “ODMDATA” to "ODMDATA=“gbe-uphy-config-25,hsstp-lane-map-3,hsio-uphy-config-3,nvhs-uphy-config-0” in “p3701.conf.common” in Jetpck 5.0.1, the orin devkit can boot up, but our board can not(our board can boot up by using config #1), the log is in the attachment , Please help to analyze the reason.
config3_error.log (25.6 KB)

@261136636
Pls follow our bring up guide to update the cvb_eeprom_read_size for your carry board.

- cvb_eeprom_read_size = <0x100>
+ cvb_eeprom_read_size = <0x0>

config3_fail_0601.txt (26.3 KB)
Hi, alanz:
It still can not boot up, the log is in the attachment , Please help to analyze.

It would need to check the UFS, PCIE, BGME Pinmux first to reflect the HW change.
if it’s ok the board should be ok to boot into the kernel, then need to work on the device tree for PCIE/UFS. Pls try according to our bring up guide.

Hi,

Could you check if there is any " gbe0-enable-10" property in your ODMDATA?

If there isn’t , please confirm if you want to enable MGBE on the board.

Behind this error, there are two possible reasons:

  1. your platform requires MGBE and gbe-uphy-config is correct, but your carrier board doesn’t enable the 156.25 MHz reference clock along with platform power-on.
  2. Your platform doesn’t require MGBE, but accidentally a wrong gbe-uphy-config is chosen.

Hi,WayneWWW:
I set “ODMDATA” to "ODMDATA=“gbe-uphy-config-25,hsstp-lane-map-3,hsio-uphy-config-3,nvhs-uphy-conf
ig-0”; it is according your guide “Adaptation and Bringup for Jetson AGX Orin.docx”;
So the boot up fail reason should 1 or 2?

That should not be me to answer. This is your carrier board… you know the answer whether that is needed…

Hi, WayneWWW:
of cource we need MGBE,and according nvidia document, I set ODMDATA to config #3, but the “gbe0-enable-10” is not in the config #3 setting “ODMDATA=gbe-uphy-config-25,hsstp-lane-map-3,hsio-uphy-config-3,nvhs-uphy-conf
ig-0”
so the reason is 1? “carrier board doesn’t enable the 156.25 MHz reference clock along with platform power-on”?

Yes, please confirm that with your hardware folks.

OK, we will confirm it.

Hi, WayneWWW:
We rework our carrier board, it can boot up now. and ufs can also works! Thanks for your support.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.