Ubuntu doesn't detect my second HDMI display

Looks fine.
According to the logs, you have 6 connectors
Mainboard: vga+hdmi+dp
Nvidia board: 2xdvi+hdmi
Only the vga port shows connected. Where did you connect the second monitor?

I have one monitor connected on the integrated graphics from my mobo (VGA), and another one on my graphics card (the monitor has an VGA connector but I have an adaptor to connect it to DVI-D)

Ok, that explains it. Please edit
/usr/share/X11/xorg.conf.d/11-nvidia-prime.conf
commenting out the line
Option “IgnoreDisplayDevices” “CRT”

Did it and rebooted, the monitor wasn’t fixed and the line was missing de “#” for the comment again

Feared so. Please try this:
create /etc/x11/xorg.conf.d/99-nvidia-ignore.conf

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option “IgnoreDisplayDevices” “TV”
EndSection

maybe this will overwrite the setting. Otherwise, you’ll have to disable gpu-manager.

Maybe try to create the file in
/usr/share/X11/xorg.conf.d/

did it and rebooted, boot stuck on a terminal screen with lots of [ OK ] some action and the last of them is
[ OK ] Reached target Sound Card.d Card State… le locally. system changes.pp link was shut down…

Ok, it’s fixed now, after the boot stuck I rebooted on recovery mode and deleted the

/usr/share/X11/xorg.conf.d/99-nvidia-ignore.conf

rebooted normally and disabled gpu-manager following these steps
and did the following again:

Ok, that explains it. Please edit
/usr/share/X11/xorg.conf.d/11-nvidia-prime.conf
commenting out the line
Option “IgnoreDisplayDevices” “CRT”

after reboot both monitors are working fine, thank you so much for the help, I appreciate it a lot!