Unable to access micro sd card

I don’t know how to access the micros sd card. Here’s output from “dmesg --follow” while I remove / install sd card.

[41796.967039] rtl_usb:rtl_usb_resume [rtl_usb]:<10000-1> Too short packet from bulk IN! (len: 44)
[42306.376098] usb 2-4: USB disconnect, device number 35
[42306.376115] usb 2-4.1: USB disconnect, device number 36
[42306.381767] usb 2-4.3: USB disconnect, device number 37
[42306.684470] usb 2-4: new SuperSpeed USB device number 38 using tegra-xusb
[42306.711065] usb 2-4: New USB device found, idVendor=045b, idProduct=0210
[42306.711083] usb 2-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[42306.714793] hub 2-4:1.0: USB hub found
[42306.715207] hub 2-4:1.0: 4 ports detected
[42307.008400] usb 2-4.1: new SuperSpeed USB device number 39 using tegra-xusb
[42307.030863] usb 2-4.1: New USB device found, idVendor=045b, idProduct=0210
[42307.030878] usb 2-4.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[42307.035281] hub 2-4.1:1.0: USB hub found
[42307.035706] hub 2-4.1:1.0: 4 ports detected
[42307.116271] usb 2-4.3: new SuperSpeed USB device number 40 using tegra-xusb
[42307.138493] usb 2-4.3: New USB device found, idVendor=1058, idProduct=0827
[42307.138508] usb 2-4.3: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[42307.138519] usb 2-4.3: Product: My Passport 0827
[42307.138530] usb 2-4.3: Manufacturer: Western Digital
[42307.138535] usb 2-4.3: SerialNumber: 575848314538353935373337
[42307.144449] usb-storage 2-4.3:1.0: USB Mass Storage device detected
[42307.164041] scsi host4: usb-storage 2-4.3:1.0
[42307.168760] usb 2-4.1: usb_suspend_both: status 0
[42308.196682] scsi 4:0:0:0: Direct-Access WD My Passport 0827 1012 PQ: 0 ANSI: 6
[42308.199077] sd 4:0:0:0: [sdc] 1953458176 512-byte logical blocks: (1.00 TB/931 GiB)
[42308.200342] sd 4:0:0:0: [sdc] Write Protect is off
[42308.200493] sd 4:0:0:0: [sdc] Mode Sense: 47 00 10 08
[42308.201089] sd 4:0:0:0: [sdc] No Caching mode page found
[42308.201239] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[42308.639679] scsi 4:0:0:1: Enclosure WD SES Device 1012 PQ: 0 ANSI: 6
[42308.849822] sdc: sdc1
[42308.855978] sd 4:0:0:0: [sdc] Attached SCSI disk
[42310.583814] usb 2-1: usb_suspend_both: status 0
[42315.471585] usb 2-1: usb_suspend_both: status 0

Any suggestions. I’m newbie

I only see lots of log from usb. Is your micro sdcard directly connecting to the slot? Or you use some converter?

micro sd card is in the xavier agx slot above the video connection. I don’t know how to access the sd card, to check the card, or use as file storage.

It looks like sdcard is not getting detected.

Are you sure you insert the sdcard? It shall be mmcblk1p1 or something similar to this name under /dev.

The method to mount can be found on google search.

I’ve tried inserting the card several time. I just tried sudo fdisk -l, and I see /dev/mmcblk0, entries from /dev/mmcblk0p1 to /dev/mmcblk0p42, /dev/mmcblk0boot1, and /dev/mmcblk0boot0. I just took the card out again, and the KOOTION micro SDXC 64 GB.

Do you have other jetson xavier devkit that can verify?

Maybe the card slot is broken.

I have a nano sitting here, that I have never turned on yet. Can you give me instructions on turning it on, hooking it up. P.S. Also, I see in the box provided to me, there’s a USB memory card reader that has micro SD card. Let me try that first…

OK, I can see the micro SD card, a file manager popped up, and it’s empty, 64GB. That makes sense. So, I guess the AXG reader is faulty, or I don’t insert it correctly. So, I guess we can close this thread. Thank you.

Actually, I don’t think there is a need to check on nano… Even if you confirmed it is working on nano, it does not represent anything to xavier.

Only use same platform with same software can prove something. Are you using pure jetpack?

I flash AGX using a cable connect to a laptop running Ubuntu, using the SDK Manager software. So I think I’m using pure jetpack, but I’m not sure how to tell. I may need to flash AGX from SD Card, does that require the on-card card reader, or can that be done using USB card reader?

No, you don’t need to flash AGX from sdcard. It is also not supported. The method you are using (flash from sdkm) is already good.

Which jetpack release are you using now?

cat /etc/nv_tegra_release
‘# R32 (release), REVISION: 5.1, GCID: 27362550, BOARD: t186ref, EABI: aarch64’

dpkg-query --show nvidia-l4t-core
nvidia-l4t-core 32.5.1-20210519111140

sudo apt-cache show nvidia-jetpack
Package: nvidia-jetpack
Version: 4.5.1-b17
Architecture: arm64
Depends: nvidia-cuda (= 4.5.1-b17), nvidia-opencv (= 4.5.1-b17), nvidia-cudnn8 (= 4.5.1-b17), nvidia-tensorrt (= 4.5.1-b17), nvidia-visionworks (= 4.5.1-b17), nvidia-container (= 4.5.1-b17), nvidia-vpi (= 4.5.1-b17), nvidia-l4t-jetson-multimedia-api (>> 32.5-0), nvidia-l4t-jetson-multimedia-api (<< 32.6-0)

hmm I don’t have xavier devkit with me at this moment. I will try micro sd once I have it.

It should not be software side problem I guess…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.