Unable to Upload Files/Folders from my Local Machine to Nucleus folders

I have several USD assets built using Isaac Sim/USD Composer. Some of these assets load OmniPBR materials which load png images for masks. I want to upload all these files and folders to my local nucleus server.

Copying or uploading has been unsuccessful.

The upload is always stuck and does not progress.

Is it possible to move assets to/from my local machine to nucleus server?

@naruto.uzumaki questions from a fellow OV user - where are you making these file transfers, directly in the OV Launcher, Navigator, Drive, etc? is the upload stuck on a specific file/folder or any file/folder? do you have the same problem going to the other way (from nucleus server to local)?

p.s. i haven’t had issues moving assets between localhost and local drive, so can’t really repro on my end.

I have tried moving assets within the OV launcher and Nucleus Navigator. In both the cases, only folders get written but no files within the folders.
Upload processes are stuck (as shown above in the sample screenshot).

I am not able to right-click and paste from my Nucleus to local drives. All my local directories are locked. Probably some write permissions are missing.

How are you moving files from nucleus <> local?

i tend to use the nucleus navigator. but haven’t had trouble with either Launcher or Navigator. when you say all of your local directories are locked, are you talking about the Users folder?

I am using Ubuntu and under My Computer, you can see the listed directories are locked. I am able to navigate within my local machine’s directories. However, all directories within my local machine have the lock icon. I am unable to download/upload.

The example videos mostly use Windows OS. I am guessing you use Windows OS?

that’s correct, i am on Windows. are subfolders of those locked foldered locked as well? because i do have a few locked folders, but not on any of the subfolders in it, which still allowed me to move files.

Yeah, the directories and subdirectories are all locked in my local machine.

is your log in username set as “omniverse”? here’s a shot in the dark - can you try something out and log out of localhost and re log in using credential admin for both username and password? this shouldn’t affect anything; you can always log back in as omniverse anytime. i am just curious whether using a different credential would affect anything.

That’s a good point.
My credentials for user and pass were “omniverse/omniverse”.
I just tested “admin/admin” for user and pass.
Still stuck. Unable to upload any files or folders into my local nucleus server.

next thing to test -do you happen to have any external drives that you can copy the files (from My Computer) onto then use the external drive to copy back into localhost? (curious to know what happens if we were to remove My Computer out of the equation)

Do you have proper access to the files on the local file system?

Can you try uploading from the nautilus file explorer into navigator that way?

Can we get some logs from navigator?

What version of nucleus and navigator are your using?

I tested with an external USB. It also appears locked and I am not able to paste files from my local machine into the USB using Nucleus Navigator. I can copy files into the USB from command line and ubuntu’s Nautilus file manager.

I am the admin and have sudo privileges. Should I do something else to have proper access to my local file system? Note that I tried running nucleus navigator from the command line:

sudo ./omniverse-navigator-linux.AppImage

All local files are still locked. I can enter my local directories and copy files, but upon pasting into nucleus localhost, the upload does not progress (please see the screenshot above).

How do I do this? Where are my nucleus contents stored in the localhost? I tried looking for my nucleus localhost, but I couldn’t find the directory.

Where may I find these logs?

I installed Nucleus from Omniverse launcher. On localhost:3080 I see this:


And Navigator version is 3.3.2.

I think that you have locks on your files means the user that you are running the app as does not have wire permissions into these folders.

When your installed omniverse, did you install it as the same user you are logged in as?

This seems to be a permissions issue from the Linux end somehow.

The logs are stored in the defined log location from launcher. The default for this is ~/.nvidia-omniverse/logs

Is there a place I can verify this? My linux username is probably not reflected inside my OV. If there is a way I can do that, please advice.
Edit: Yes, I installed it with the same user credentials as I logged into my OS. But if there are any verification I can do, please let me know.

In this directory, I have one log for navigator: navigator.log.

navigator.log (105.2 KB)

I would just need read permissions if I am trying to copy files from my local machine into the nucleus localhost right? Trying to solve one problem at a time.
With Nautilus file manager, I am able to move files anywhere within my local machine. Is there a way I can use nautilus to move files into my nucleus’ localhost? (not using navigator/OV launcher)

You can upload using the connect sample, this has an omnicli.bat file that you can use to upload directly to Nucleus. If you have composer installed, you can upload in the content browser. You’ll have to build the connect sample, but you’ll get a way to upload with a command line.


Can I ask what version of nucleus are you using?

Can we get the verbose logs files from your copy commands?

I have been trying to work with omnicli.sh.
I am getting strange outputs. It is able to copy the contents from some folders but not others.
I first tried copying over the parent directory from my host to nucleus localhost assuming it will recursively copy over all the sub-directories as well.

Let’s say my directory work tree is as follows:

├── furniture
│   ├── extras
│   │   ├── images                      # only has png images
│   │   └── textures                    # only has png images
│   ├── props
│   │   ├── cups                        # has usd, and textures dir with more images
│   │   ├── mugs                        # has usd, and textures dir with more images
│   │   ├── carpet
│   │   ├── floor
│   │   ├── materials
│   │   └── chairs
│   ├── test
│   │   ├── a.png
│   │   ├── a.txt
│   │   └── a.usd
│   └── stage
│       └── my_room.usd

I ran the command:

omnicli.sh cp /home/$USER/furniture omniverse://localhost/Projects/

It copied just extras/images with all the images within, but didn’t copy anything else. The output of the command is:

Running script in /home/$USER/.local/share/ov/pkg/connectsample-203.0.0

The directories are just 10-20 MB and some directories are just KB of data.

Then I worked my way through to individually copy one sub-directory at at time. This way I was able to copy furniture/extras/textures/ and all the images within.

Then I worked my way to furniture/props/cups (copied).

But then got stuck with furniture/props/mugs. Within mugs, I have another sub-directory called textures which only has png images. I tried copying just the images from furniture/props/mugs/textures and it is stuck. Note that the images are just a few KBs.

Is this expected outcome?

In Ubuntu 20.04, I am easily able to copy files between nucleus and host (tested with Isaac Sim). But on Ubuntu 22.04, it’s been extremely difficult and unreliable outcomes.

How can I move folders? Can you test this on Ubuntu 22.04?


Is the command for this the following?

./omnicli.sh cp <src> <dst> -v

I tested the above and got:

Running script in /home/$USER/.local/share/ov/pkg/connectsample-203.0.0