Upgrade to Jetpack 5.1.1 failed

I tried to upgrade to Jetpack 5.1.1 on AGX Orin and met the following error. Could you let me know how to fix it?

andy@andy-orin:~/nvidia/spconv$ sudo apt install --fix-broken -o Dpkg::Options::=“–force-overwrite”
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
apt-clone archdetect-deb bogl-bterm busybox-static cmake-data cryptsetup-bin dctrl-tools dpkg-repack gdal-data gir1.2-goa-1.0 gir1.2-timezonemap-1.0 gir1.2-xkl-1.0 grub-common libarmadillo9
libarpack2 libavcodec-dev libavformat-dev libavresample-dev libavresample4 libavutil-dev libcfitsio8 libcharls2 libdap25 libdapclient6v5 libdc1394-22-dev libdebian-installer4 libepsilon1
libexif-dev libfreexl1 libfwupdplugin1 libfyba0 libgdal26 libgdcm-dev libgdcm3.0 libgeos-3.8.0 libgeos-c1v5 libgeotiff5 libgl2ps1.4 libgphoto2-dev libhdf4-0-alt libilmbase-dev libjbig-dev
libjsoncpp1 libkmlbase1 libkmldom1 libkmlengine1 liblept5 liblzma-dev libminizip1 libnetcdf-c++4 libnetcdf15 libodbc1 libogdi4.1 libopencv-calib3d4.2 libopencv-contrib4.2 libopencv-dnn4.2
libopencv-features2d4.2 libopencv-flann4.2 libopencv-highgui4.2 libopencv-imgcodecs4.2 libopencv-imgproc4.2 libopencv-ml4.2 libopencv-objdetect4.2 libopencv-photo4.2 libopencv-shape4.2
libopencv-stitching4.2 libopencv-superres4.2 libopencv-video4.2 libopencv-videoio4.2 libopencv-videostab4.2 libopencv-viz4.2 libopencv4.2-java libopencv4.2-jni libopenexr-dev libpng-dev
libpq5 libproj15 libqhull7 libraw1394-dev librhash0 libsocket++1 libspatialite7 libsuperlu5 libswresample-dev libswscale-dev libtbb-dev libtesseract4 libtiff-dev libtiffxx5
libtimezonemap-data libtimezonemap1 liburiparser1 libvtk6.3 libxerces-c3.2 libxmlb1 nsight-systems-2022.2.3 nsight-systems-linux-tegra-public-2021.5.4.20-6e27cb6 nvidia-opencv-runtime
odbcinst odbcinst1debian2 os-prober proj-data python3-icu python3-pam rdate tasksel tasksel-data
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up nvidia-l4t-bootloader (35.3.1-20230319081403) …
Info. Active boot storage: nvme0n1
Info. Legacy mode: true
TNSPEC 3701-500-0000-H.0-1-1-jetson-agx-orin-devkit-mmcblk0p1
COMPATIBLE_SPEC 3701-300-0000–1–jetson-agx-orin-devkit-
TEGRA_OTA_BOOT_DEVICE /dev/mtdblock0
TEGRA_OTA_GPT_DEVICE /dev/mtdblock0
Error: uuid of esp is not found.
ERROR. Mount active boot media’s esp failed.
Cannot install capsule package. Exiting…
dpkg: error processing package nvidia-l4t-bootloader (–configure):
installed nvidia-l4t-bootloader package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


what’s the complete step you tried to upgrade JetPack?
Did you follow all the steps as shown in the link below?

Also, based on the log, you are using the official DevKit with an NVMe SSD, right?

I follow the document you shared to upgrade the JetPack. However I’m not using the official DevKit and doesn’t have NVMe SSD, would this be the issue?


yes, APT-based OTA is not supported for devices with custom carrier board.
Please try image-based OTA as shown in the link:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.