[Urgent] Cann't using display with jetson nano

Hello, I’m using jetson nano, a few days ago, my jetson still working correctly and I can using my screen normally (with 5V-4A power). But when I tried to use it with 5V-2A power, my Jetson can’t boot and (the green led light up a few seconds and turn off). I use a converter cable from VGA to HDMI to connect my screen with my Jetson and this cable was damaged, I tried a new one and it also is damaged when I plug into Jetson.
Not only that, my OS on the SD card is damaged, so I tried to create a new one and it may work but I can’t verify it without the screen.
So anyone who has experience about this problem can show what I need to do? Many thanks.
So do I need to buy a new screen that has HDMI connection?

I think VGA to HDMI converters are not supported. If you can repair your sd card and you have access to a native ubuntu computer, try to install the jetson nano through the Nvidia SDK manager, in my opinion works better.
Probably yes, the screen with an HDMI connection will be the best

Thank you, FelipeVW.
Before I tried with 5V-2.5A power, the converter still working correctly. I don’t know why.
But Nvidia SDK Manager is a great idea, I will try it.