Vino VNC Terribly Slow

Hi all.

Successfully set up Vino VNC server as described in the manual files on Jetson Nano desktop, it starts automatically with auto login turned on every time Nano boots, but it is incredibly slow to react - it takes about 2 seconds to react to either a click or a button press. Strangely enough in fact it is slow only to display it via VNC - everything executes almost immediately on the physical screen attached via HDMI.

Any ideas on making Vino snappier?

P.S.: FYI RasPi 3 with RealVNC Server flies on the same WiFi network with all the same conditions, so has to be an issue with Vino

I have no experience with Vino, but it may be a significant amount of data to be sent from Jetson, so you may try to increase TX buffers with:

sudo sysctl -w net.core.wmem_max=33554432
sudo sysctl -w net.core.wmem_default=33554432

Oh, many thanks, will try.
Update: I tried and it didn’t help much - here’s the video I recorded of how slow it actually is. You can hear me typing and clicking and actually see when the changes appear 😔

sudo sysctl -w net.core.wmem_max=33554432
sudo sysctl -w net.core.wmem_default=33554432

What are the default values for those just in case?

Default values are both 212992.
You should get that again after reboot.

Maybe some more ideas? 💡

Someone more experienced with Vino and Nano may better advise.

My only ideas so far would be:

  • Check encryption is disabled for Vino server.
  • Try wired ethernet. Wifi errors may give such problems. You would check /var/log/syslog on Nano for wifi errors. If some are logged, you may check the wifi interface addresses and config, and/or change channel.
  • If wired ethernet is not better, you may try another virtual desktop such as NoMachine.

Try using a different vnc-viewer. For me remmina was lagging but gnome-boxes works much better.

Thanks for an idea, but I’am actually using it via default VNC support built into Finder in macOS, though I tried RealVNC Viewer on Mac/iPad as well - result is the same 🤷‍♂️

Hi, thanks for your ideas

Here comes the answers:

  1. I don’t use encryption, so it’s surely not the cause of the problem
    2 & 3. Will test it tomorrow - might be of help, so will post here later

For now I’ve removed Vino and installed a tigervnc-scraping-server. It is still slow for my liking, but definitely snappier than Vino. I used this link as a guide

Update 1: tigervnc-scraping-server is indeed faster and is almost usable, except for there is a weird bug with kepresses - sometimes some of the keys I type will get lost, but some might get duplicated for some reason up to 10 times - it makes coding or even entering a password a total nightmare, so also no good 😔

Update 2: I installed nomachine and it works totally fine - not perfectly real-time, yet pretty comfortable - seems like it’s the best solution for now, though I will give Vino a try with ethernet connection later just out of curiosity

Update3: I did test ethernet connection and it’s just the same - not a single bit of difference vs WiFi.

So for now NoMachine feels best, but I’am looking forward to being able to run RealVNC Server on Jetson Nano some day 🤞

Btw has anyone tried installing RealVNC Server on Jetson Nano? I did but was unable to get it to work 🤷‍♂️ Anyone had better luck?

Hi alexanderre,

Please try use TightVNC, connect host and target to the same LAN hub.
You can reference this topic.